From: sms Subject: Fix CVE-2014-8140: out-of-bounds write issue in test_compr_eb() Bug-Debian: http://bugs.debian.org/773722 --- a/extract.c +++ b/extract.c @@ -2234,10 +2234,17 @@ if (compr_offset < 4) /* field is not compressed: */ return PK_OK; /* do nothing and signal OK */ + /* Return no/bad-data error status if any problem is found: + * 1. eb_size is too small to hold the uncompressed size + * (eb_ucsize). (Else extract eb_ucsize.) + * 2. eb_ucsize is zero (invalid). 2014-12-04 SMS. + * 3. eb_ucsize is positive, but eb_size is too small to hold + * the compressed data header. + */ if ((eb_size < (EB_UCSIZE_P + 4)) || - ((eb_ucsize = makelong(eb+(EB_HEADSIZE+EB_UCSIZE_P))) > 0L && - eb_size <= (compr_offset + EB_CMPRHEADLEN))) - return IZ_EF_TRUNC; /* no compressed data! */ + ((eb_ucsize = makelong( eb+ (EB_HEADSIZE+ EB_UCSIZE_P))) == 0L) || + ((eb_ucsize > 0L) && (eb_size <= (compr_offset + EB_CMPRHEADLEN)))) + return IZ_EF_TRUNC; /* no/bad compressed data! */ if ( #ifdef INT_16BIT s='active' href='/guix/log/gnu/services/telephony.scm'>logtreecommitdiff
path: root/gnu/services/telephony.scm
AgeCommit message (Expand)Author
2023-12-22services: jami: Use ‘least-authority-wrapper’....Ludovic Courtès
2023-12-22services: jami-dbus-session: Use ‘least-authority-wrapper’....Ludovic Courtès
2023-10-07services: configuration: Add some commonly used predicates....Bruno Victal
2023-10-07services: configuration: Use transducers within serialize-configuration....Bruno Victal
2023-02-08gnu: libjami: Move jamid daemon to a "bin" output....Maxim Cournoyer
2022-09-23services: jami-service-type: Streamline stop slot....Maxim Cournoyer
2022-08-25services: Use the new maybe/unset API....Attila Lendvai
2022-08-01services: configuration: Step back from *unspecified*....Maxim Cournoyer
2022-06-15services: configuration: Use *unspecified* instead of 'disabled....Attila Lendvai
2022-06-10services: jami-configuration: Rename 'jamid' field to 'libjami'....Maxim Cournoyer
2022-06-10services: jami: Modernize to adjust to Shepherd 0.9+ changes....Maxim Cournoyer