From: sms Subject: Fix CVE-2014-8140: out-of-bounds write issue in test_compr_eb() Bug-Debian: http://bugs.debian.org/773722 --- a/extract.c +++ b/extract.c @@ -2234,10 +2234,17 @@ if (compr_offset < 4) /* field is not compressed: */ return PK_OK; /* do nothing and signal OK */ + /* Return no/bad-data error status if any problem is found: + * 1. eb_size is too small to hold the uncompressed size + * (eb_ucsize). (Else extract eb_ucsize.) + * 2. eb_ucsize is zero (invalid). 2014-12-04 SMS. + * 3. eb_ucsize is positive, but eb_size is too small to hold + * the compressed data header. + */ if ((eb_size < (EB_UCSIZE_P + 4)) || - ((eb_ucsize = makelong(eb+(EB_HEADSIZE+EB_UCSIZE_P))) > 0L && - eb_size <= (compr_offset + EB_CMPRHEADLEN))) - return IZ_EF_TRUNC; /* no compressed data! */ + ((eb_ucsize = makelong( eb+ (EB_HEADSIZE+ EB_UCSIZE_P))) == 0L) || + ((eb_ucsize > 0L) && (eb_size <= (compr_offset + EB_CMPRHEADLEN)))) + return IZ_EF_TRUNC; /* no/bad compressed data! */ if ( #ifdef INT_16BIT og/tests/services'>logtreecommitdiff
path: root/tests/services
AgeCommit message (Expand)Author
2023-04-02services: replace bare serializers with (serializer ...)...Bruno Victal
2023-04-02services: configuration: Add user-defined sanitizer support....Bruno Victal
2022-08-28services: Add lightdm-service-type....Maxim Cournoyer
2022-08-25services: configuration: Change the value of the unset marker....Attila Lendvai
2022-08-25services: Use the new maybe/unset API....Attila Lendvai
2022-08-09tests: configuration: Add a test to cover 'unset regression....Maxim Cournoyer
2022-08-01services: configuration: Step back from *unspecified*....Maxim Cournoyer
2022-07-07tests: telephony: Remove obsolete parsing tests....Maxim Cournoyer
2022-06-24services: configuration: Report the location of field type errors....Ludovic Courtès
2022-06-15services: configuration: Use *unspecified* instead of 'disabled....Attila Lendvai
2022-06-15services: configuration: Support (field1 maybe-number "") format....Attila Lendvai