Build with the system NSPR library instead of the bundled version. Originally based on this Debian patch: https://salsa.debian.org/chromium-team/chromium/-/blob/master/debian/patches/system/nspr.patch diff --git a/base/BUILD.gn b/base/BUILD.gn --- a/base/BUILD.gn +++ b/base/BUILD.gn @@ -184,6 +184,12 @@ buildflag_header("ios_cronet_buildflags") { flags = [ "CRONET_BUILD=$is_cronet_build" ] } +if (is_linux) { + ldflags = [ + "-lnspr4", + ] +} + # Base and everything it depends on should be a static library rather than # a source set. Base is more of a "library" in the classic sense in that many # small parts of it are used in many different contexts. This combined with a @@ -838,8 +844,6 @@ mixed_component("base") { "third_party/cityhash_v103/src/city_v103.cc", "third_party/cityhash_v103/src/city_v103.h", "third_party/icu/icu_utf.h", - "third_party/nspr/prtime.cc", - "third_party/nspr/prtime.h", "third_party/superfasthash/superfasthash.c", "thread_annotations.h", "threading/hang_watcher.cc", diff --git a/base/time/pr_time_unittest.cc b/base/time/pr_time_unittest.cc --- a/base/time/pr_time_unittest.cc +++ b/base/time/pr_time_unittest.cc @@ -6,7 +6,7 @@ #include #include "base/compiler_specific.h" -#include "base/third_party/nspr/prtime.h" +#include #include "base/time/time.h" #include "build/build_config.h" #include "testing/gtest/include/gtest/gtest.h" diff --git a/base/time/time.cc b/base/time/time.cc --- a/base/time/time.cc +++ b/base/time/time.cc @@ -21,7 +21,7 @@ #include #include "base/strings/stringprintf.h" -#include "base/third_party/nspr/prtime.h" +#include #include "base/time/time_override.h" #include "build/build_config.h" #include "third_party/abseil-cpp/absl/types/optional.h" ect>
AgeCommit message (Expand)Author
2022-10-22Remove now unnecessary uses of (guix grafts)....Ludovic Courtès
2021-09-17tests: Add missing module import....Marius Bakke
2021-09-07tests: Disable grafts in 'tests/builders.scm'....Ludovic Courtès
2021-07-05tests: Adjust Python "sanity" check tests....Ludovic Courtès
2021-03-30build-system: Rewrite using gexps....Ludovic Courtès
2021-02-01build/python: Add a sanity check phase....Lars-Dominik Braun
2021-01-26build-systems/gnu: Allow unpacking/repacking more kind of files....Maxim Cournoyer
2019-06-14tests: Remove expensive and pointless test....Ludovic Courtès
2018-09-22bootstrap: %bootstrap-inputs: Wrap input lists into thunks....Jan Nieuwenhuizen
2018-09-04Switch to Guile-Gcrypt....Ludovic Courtès