Look for extensions in $CHROMIUM_EXTENSION_DIRECTORY instead of /usr/share/chromium/extensions. --- a/chrome/common/chrome_paths.cc +++ b/chrome/common/chrome_paths.cc @@ -4,6 +4,7 @@ #include "chrome/common/chrome_paths.h" +#include "base/environment.h" #include "base/files/file_util.h" #include "base/logging.h" #include "base/native_library.h" @@ -511,7 +512,13 @@ #endif #if defined(OS_LINUX) || defined(OS_CHROMEOS) case chrome::DIR_STANDALONE_EXTERNAL_EXTENSIONS: { - cur = base::FilePath(kFilepathSinglePrefExtensions); + std::unique_ptr environment(base::Environment::Create()); + std::string extension_dir; + if (environment->GetVar("CHROMIUM_EXTENSION_DIRECTORY", &extension_dir)) { + cur = base::FilePath(extension_dir); + } else { + cur = base::FilePath(kFilepathSinglePrefExtensions); + } break; } #endif ss='sub right'>
aboutsummaryrefslogtreecommitdiff
path: root/tests/glob.scm
ge (Collapse)
AgeCommit message (Expand)Author
Author
2021-11-17Merge branch 'master' into core-updates-frozenLudovic Courtès
2021-11-14tests: Adjust tests/egg.scm to latest API changes.Ludovic Courtès
This is a followup to b999c80c2e71bd4b3f26a18a321b7e7e7b580103. * tests/egg.scm (eval-test-with-egg-file): Pass 'version' argument to 'egg->guix-package'.
2021-07-20import: egg: Emit new-style package inputs.Sarah Morgensen
* guix/import/egg.scm (egg->guix-package): Generate dependency list from a list of symbols. [egg-parse-dependency]: Return a list of symbols. [maybe-inputs]: Wrap INPUTS in 'list' instead of 'quasiquote'. * tests/egg.scm (match-chicken-foo): Adjust accordingly. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
2021-06-03import: Add CHICKEN egg importer.Xinglu Chen
* guix/import/egg.scm: New file. * guix/scripts/import/egg.scm: New file. * tests/egg.scm: New file. * Makefile.am (MODULES, SCM_TESTS): Register them. * po/guix/POTFILES.in: Likewise. * guix/scripts/import.scm (importers): Add egg importer. * doc/guix.texi (Invoking guix import, Invoking guix refresh): Document it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>