Remove references to FreeSans font, which is not packaged for Guix.
--- a/game/fonts/fonts.ini 1970-01-01 01:00:01.000000000 +0100
+++ b/game/fonts/fonts.ini 2022-09-16 14:31:51.483096847 +0200
@@ -116,26 +116,6 @@
BoldHighResPreCache=0
BoldHighResOutline=0.02
-[Font_FreeSans]
-Name=Free Sans
-RegularFile=FreeSans/FreeSans.ttf
-RegularFallbackFile1=wqy-microhei/wqy-microhei.ttc
-;RegularGlyphSpacing=1.4
-;RegularStretch=1.2
-BoldFile=FreeSans/FreeSansBold.ttf
-BoldFallbackFile1=wqy-microhei/wqy-microhei.ttc
-;BoldEmbolden=0.06
-OutlineFile=FreeSans/FreeSansBold.ttf
-OutlineOutline=0.06
-;OutlineColorR=0.3
-;OutlineColorG=0.3
-;OutlineColorB=0.3
-;OutlineColorA=0.3
-BoldHighResFile=FreeSans/FreeSansBold.ttf
-BoldHighResMaxResolution=256
-BoldHighResPreCache=0
-BoldHighResOutline=0.02
-
[Font_DejaVuSans]
Name=DejaVu Sans
RegularFile=DejaVu/DejaVuSans.ttf
pe='submit' value='switch'/>
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2022-09-07 | system: images: Define the platform in image-types....Running the following command where my-pine.scm contains an operating-system
declaration:
guix system image --image-type=pine64-raw my-pine.scm
returns:
guix system: error: package linux-libre-arm64-generic@5.18.19 does not support
x86_64-linux
That's because there's no platform defined in the pine64-raw image-type, hence
the guix system image tries to build the image for the host architecture.
* gnu/system/images/novena.scm (novena-image-type): Use the armv7-linux platform.
* gnu/system/images/pine64.scm (pine64-image-type): Use the aarch64-linux platform.
* gnu/system/images/pinebook-pro.scm (pinebook-pro-image-type): Use the aarch64-linux platform.
* gnu/system/images/rock64.scm (rock64-image-type): Use the aarch64-linux platform.
| Mathieu Othacehe |
2022-05-25 | Move (gnu platform) and (gnu platforms ...) to guix/....* gnu/platform.scm:
* gnu/platforms/arm.scm:
* gnu/platforms/hurd.scm:
* gnu/platforms/mips.scm:
* gnu/platforms/powerpc.scm:
* gnu/platforms/riscv.scm:
* gnu/platforms/s390.scm:
* gnu/platforms/x86.scm: Move to guix/.
* Makefile.am:
* doc/guix.texi (Porting to a New Platform):
* etc/release-manifest.scm:
* gnu/ci.scm:
* gnu/image.scm:
* gnu/local.mk:
* gnu/packages/bioinformatics.scm:
* gnu/packages/bootstrap.scm:
* gnu/packages/cross-base.scm:
* gnu/packages/instrumentation.scm:
* gnu/packages/linux.scm:
* gnu/system/image.scm:
* gnu/system/images/hurd.scm:
* gnu/system/images/novena.scm:
* gnu/system/images/pine64.scm:
* gnu/system/images/pinebook-pro.scm:
* gnu/system/images/rock64.scm:
* guix/scripts/build.scm:
* guix/scripts/system.scm:
* guix/self.scm: Update (gnu platform...) to (guix platform...).
Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
| Josselin Poiret |