--- tuxpaint-0.9.22/src/tuxpaint.c +++ tuxpaint-0.9.22/src/tuxpaint.c @@ -7474,11 +7474,21 @@ static void load_stamps(SDL_Surface * screen) { char *homedirdir = get_fname("stamps", DIR_DATA); + char *stamps_path = getenv("TUXPAINT_STAMPS_PATH"); default_stamp_size = compute_default_scale_factor(1.0); load_stamp_dir(screen, homedirdir); load_stamp_dir(screen, DATA_PREFIX "stamps"); + /* Load any stamps in TUXPAINT_STAMPS_PATH */ + if (stamps_path) { + char *token; + token = strtok(stamps_path, ":"); + while (token != NULL) { + load_stamp_dir(screen, token); + token = strtok(NULL, ":"); + } + } #ifdef __APPLE__ load_stamp_dir(screen, "/Library/Application Support/TuxPaint/stamps"); #endif value='koszko' selected='selected'>koszko Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/tests/guix-package-net.sh
AgeCommit message (Expand)Author
2019-06-14tests: Make builds less expensive....Ludovic Courtès
2019-01-15guix package: '--upgrade' preserves package order....Ludovic Courtès
2017-06-02tests: Remove 't-profile-alt-*-link' files....Ludovic Courtès
2017-01-23guix package: Honor the order of profiles when -p appears multiple times....Ludovic Courtès
2015-11-11guix package: '--search-paths' can report combined search paths....Ludovic Courtès
2015-05-20guix package: Add optional argument to --search-paths....Ludovic Courtès
2015-04-08tests: Skip 'guix-package-net.sh' when prerequisites aren't met....Ludovic Courtès
2015-04-06tests: Move 'guix package' tests that require networking to a separate file....Ludovic Courtès