--- tuxpaint-0.9.22/src/tuxpaint.c +++ tuxpaint-0.9.22/src/tuxpaint.c @@ -7474,11 +7474,21 @@ static void load_stamps(SDL_Surface * screen) { char *homedirdir = get_fname("stamps", DIR_DATA); + char *stamps_path = getenv("TUXPAINT_STAMPS_PATH"); default_stamp_size = compute_default_scale_factor(1.0); load_stamp_dir(screen, homedirdir); load_stamp_dir(screen, DATA_PREFIX "stamps"); + /* Load any stamps in TUXPAINT_STAMPS_PATH */ + if (stamps_path) { + char *token; + token = strtok(stamps_path, ":"); + while (token != NULL) { + load_stamp_dir(screen, token); + token = strtok(NULL, ":"); + } + } #ifdef __APPLE__ load_stamp_dir(screen, "/Library/Application Support/TuxPaint/stamps"); #endif Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-14 03:47:04 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-14 03:50:18 +0100
commit767b44270d28cd30896adfecda390676b6fe3f5a (patch)
treed6a1c0ce2bf342fab5fe98911558348b9cbf2ca6 /gnu
parent11bf3b2f0391225b159ae26eca4871a19ad947e0 (diff)
downloadguix-767b44270d28cd30896adfecda390676b6fe3f5a.tar.gz
guix-767b44270d28cd30896adfecda390676b6fe3f5a.zip
gnu: libdvdread: Don't use NAME in source URI.
* gnu/packages/video.scm (libdvdread)[source]: Hard-code NAME.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index aa7930aad7..9c27272f18 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1638,8 +1638,8 @@ players, like VLC or MPlayer.")
(source (origin
(method url-fetch)
(uri (string-append "https://download.videolan.org/videolan/"
- name "/" version "/"
- name "-" version ".tar.bz2"))
+ "libdvdread/" version "/"
+ "libdvdread-" version ".tar.bz2"))
(sha256
(base32
"0dgr23fzcjhb7ck54xkr9zmf4jcq3ph0dz3fbyvla1c6ni9ijfxk"))))