--- tuxpaint-0.9.22/src/tuxpaint.c +++ tuxpaint-0.9.22/src/tuxpaint.c @@ -7474,11 +7474,21 @@ static void load_stamps(SDL_Surface * screen) { char *homedirdir = get_fname("stamps", DIR_DATA); + char *stamps_path = getenv("TUXPAINT_STAMPS_PATH"); default_stamp_size = compute_default_scale_factor(1.0); load_stamp_dir(screen, homedirdir); load_stamp_dir(screen, DATA_PREFIX "stamps"); + /* Load any stamps in TUXPAINT_STAMPS_PATH */ + if (stamps_path) { + char *token; + token = strtok(stamps_path, ":"); + while (token != NULL) { + load_stamp_dir(screen, token); + token = strtok(NULL, ":"); + } + } #ifdef __APPLE__ load_stamp_dir(screen, "/Library/Application Support/TuxPaint/stamps"); #endif tion value='koszko' selected='selected'>koszko Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/installer/newt/wifi.scm
AgeCommit message (Expand)Author
2019-08-26installer: Hide the Wi-Fi passphrase by default....Tobias Geerinckx-Rice
2019-05-29installer: Fix wifi menu crash with hidden SSIDs....Mathieu Othacehe
2019-04-29installer: Fix typo in docstring....Meiyo Peng
2019-02-18gnu: Fix some typos in the installer....Tobias Geerinckx-Rice
2019-01-17installer: Make sure every sentence is dot terminated....Mathieu Othacehe
2019-01-17installer: Turn "Cancel" buttons into "Exit" buttons....Mathieu Othacehe
2019-01-17installer: Remove "selection" from all titles....Mathieu Othacehe
2019-01-17gnu: Add graphical installer support....Mathieu Othacehe