--- tuxpaint-0.9.22/src/tuxpaint.c +++ tuxpaint-0.9.22/src/tuxpaint.c @@ -7474,11 +7474,21 @@ static void load_stamps(SDL_Surface * screen) { char *homedirdir = get_fname("stamps", DIR_DATA); + char *stamps_path = getenv("TUXPAINT_STAMPS_PATH"); default_stamp_size = compute_default_scale_factor(1.0); load_stamp_dir(screen, homedirdir); load_stamp_dir(screen, DATA_PREFIX "stamps"); + /* Load any stamps in TUXPAINT_STAMPS_PATH */ + if (stamps_path) { + char *token; + token = strtok(stamps_path, ":"); + while (token != NULL) { + load_stamp_dir(screen, token); + token = strtok(NULL, ":"); + } + } #ifdef __APPLE__ load_stamp_dir(screen, "/Library/Application Support/TuxPaint/stamps"); #endif koszko' selected='selected'>koszko Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/kodi.scm
AgeCommit message (Expand)Author
2017-06-20gnu: Move contents of zip module into compression module....Arun Isaac
2017-06-04gnu: kodi: Update to 18.0_alpha-6-f22d62d....Marius Bakke
2017-05-25gnu: kodi: Update to 18.0_alpha-5-1a38948....Marius Bakke
2017-05-09gnu: kodi: Update to 18.0_alpha-4-b8ad238....Marius Bakke
2017-04-27gnu: kodi: Update to 18.0_alpha-3-749c61e....Marius Bakke
2017-04-15gnu: kodi: Update to 18.0_alpha-2-478d306....Marius Bakke
2017-03-30gnu: kodi: Update to 18.0_alpha-1-ec5d53d....Marius Bakke
2017-03-30gnu: kodi: Remove silly wrapper script....Marius Bakke
2017-03-30gnu: kodi: Embed full path to tzdata....Marius Bakke
2017-03-21gnu: kodi: Wrap executable so it finds libcurl....Marius Bakke
2017-03-20gnu: kodi: Update to 18.0_alpha-0-b35147e....Marius Bakke
2016-09-28gnu: Add and use gettext-minimal....Alex Kost
2016-06-21gnu: Adjust to yasm change of module....Ludovic Courtès
2016-05-12gnu: Update module imports for asciidoc and doxygen....Mark H Weaver
2016-03-26gnu: crossguid: Set explicit file name for source checkout....David Thompson
2016-03-19gnu: kodi: Remove @acronym from description....Ludovic Courtès
2016-03-14gnu: kodi: Update to 16.0....David Thompson
2016-03-14gnu: Add crossguid....David Thompson