--- tuxpaint-0.9.22/src/tuxpaint.c +++ tuxpaint-0.9.22/src/tuxpaint.c @@ -7474,11 +7474,21 @@ static void load_stamps(SDL_Surface * screen) { char *homedirdir = get_fname("stamps", DIR_DATA); + char *stamps_path = getenv("TUXPAINT_STAMPS_PATH"); default_stamp_size = compute_default_scale_factor(1.0); load_stamp_dir(screen, homedirdir); load_stamp_dir(screen, DATA_PREFIX "stamps"); + /* Load any stamps in TUXPAINT_STAMPS_PATH */ + if (stamps_path) { + char *token; + token = strtok(stamps_path, ":"); + while (token != NULL) { + load_stamp_dir(screen, token); + token = strtok(NULL, ":"); + } + } #ifdef __APPLE__ load_stamp_dir(screen, "/Library/Application Support/TuxPaint/stamps"); #endif koszko' selected='selected'>koszko Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/tests/guix-package.sh
AgeCommit message (Expand)Author
2019-02-07profiles: Raise an error for unmatched patterns....Ludovic Courtès
2018-11-11guix package: '--show' errors when asked for a non-existent package....Ludovic Courtès
2018-09-21profiles: 'packages->manifest' now accepts inferior packages....Ludovic Courtès
2018-07-13guix package: Use relative symlinks to generations....Ludovic Courtès
2018-06-06tests: Adjust 'guix package' test to "python2" name....Ludovic Courtès
2018-03-31guix package: Add '--allow-collisions'....Ludovic Courtès
2018-02-27guix package: '--search' no longer shows superseded packages....Ludovic Courtès
2017-11-11tests: Adjust to new unbound-variable error message....Ludovic Courtès