--- tuxpaint-0.9.22/src/tuxpaint.c +++ tuxpaint-0.9.22/src/tuxpaint.c @@ -7474,11 +7474,21 @@ static void load_stamps(SDL_Surface * screen) { char *homedirdir = get_fname("stamps", DIR_DATA); + char *stamps_path = getenv("TUXPAINT_STAMPS_PATH"); default_stamp_size = compute_default_scale_factor(1.0); load_stamp_dir(screen, homedirdir); load_stamp_dir(screen, DATA_PREFIX "stamps"); + /* Load any stamps in TUXPAINT_STAMPS_PATH */ + if (stamps_path) { + char *token; + token = strtok(stamps_path, ":"); + while (token != NULL) { + load_stamp_dir(screen, token); + token = strtok(NULL, ":"); + } + } #ifdef __APPLE__ load_stamp_dir(screen, "/Library/Application Support/TuxPaint/stamps"); #endif koszko' selected='selected'>koszko Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/services/mail.scm
AgeCommit message (Expand)Author
2020-09-11Revert "services: dovecot: Use modules via symlink to system profile."...Tobias Geerinckx-Rice
2020-09-11services: dovecot: Only serialize settings with non-empty values....Alexey Abramov
2020-09-09services: dovecot: Serialize global settings first....Alexey Abramov
2020-09-09services: dovecot: Use modules via symlink to system profile....Alexey Abramov
2020-04-21services: dovecot: 'stop' method returns #f upon success....Ludovic Courtès
2020-03-16tests: opensmtpd: Check /var/spool/mail instead of /var/mail....Ludovic Courtès
2020-01-31gnu: Update opensmtpd configuration grammar....Tobias Geerinckx-Rice
2019-09-21services: dovecot: Fix predicate names for free-form fields...Alexey Abramov
2019-06-20services: opensmtpd: Extend the PAM service....Kristofer Buffington
2019-06-20services: Fix typo in (gnu services mail) exports....Tobias Geerinckx-Rice
2019-05-07services: dovecot: Rename auth-verbose-passwords?....Christopher Baines
2019-04-07services: Add 'imap4d-service-type'....宋文武
2019-03-13Remove traces of "GuixSD"....Ludovic Courtès
2018-11-10services: dovecot: Set correct default value for the "auth" service....Clément Lassieur
2018-11-10services: dovecot: Allow to set 'process-limit'....Clément Lassieur
2018-11-10services: dovecot: Allow to set 'client-limit'....Clément Lassieur