--- tuxpaint-0.9.22/src/tuxpaint.c
+++ tuxpaint-0.9.22/src/tuxpaint.c
@@ -7474,11 +7474,21 @@
static void load_stamps(SDL_Surface * screen)
{
char *homedirdir = get_fname("stamps", DIR_DATA);
+ char *stamps_path = getenv("TUXPAINT_STAMPS_PATH");
default_stamp_size = compute_default_scale_factor(1.0);
load_stamp_dir(screen, homedirdir);
load_stamp_dir(screen, DATA_PREFIX "stamps");
+ /* Load any stamps in TUXPAINT_STAMPS_PATH */
+ if (stamps_path) {
+ char *token;
+ token = strtok(stamps_path, ":");
+ while (token != NULL) {
+ load_stamp_dir(screen, token);
+ token = strtok(NULL, ":");
+ }
+ }
#ifdef __APPLE__
load_stamp_dir(screen, "/Library/Application Support/TuxPaint/stamps");
#endif
ct name='h' onchange='this.form.submit();'>
Wojtek's customized Guix | |
Age | Commit message (Collapse) | Author |
|
* gnu/service/sound.scm: Export ladspa-configuration? and
ladspa-configuration-plugins.
(<ladspa-configuration>)[plugins]: Rename accessor to ladspa-configuration-plugins.
(ladspa-environment): Adjust to use renamed plugin accessor.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
|
|
* gnu/services/sound.scm: Export alsa-configuration?,
alsa-configuration-alsa-plugins, alsa-configuration-pulseaudio?
and alsa-configuration-extra-options.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
|
|
* gnu/services/sound.scm: Export pulseaudio-configuration?,
pulseaudio-configuration-client-conf, pulseaudio-configuration-daemon-conf,
pulseaudio-configuration-script-file, pulseaudio-configuration-extra-script-files
and pulseaudio-configuration-system-script-file.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
|