Allow building tup after removing some bundled sources from the source tree. diff --git a/build.sh b/build.sh index 2937116d..eab650f7 100755 --- a/build.sh +++ b/build.sh @@ -16,7 +16,7 @@ else echo "Error: invalid TUP_SERVER \"$server\"" 1>&2 exit 1 fi -LDFLAGS="$LDFLAGS -lm" +LDFLAGS="$LDFLAGS -lm -lsqlite3 `pcre-config --libs`" : ${CC:=gcc} case "$os" in Linux) @@ -65,17 +65,15 @@ mkdir luabuiltin CFLAGS="$CFLAGS -DTUP_SERVER=\"$server\"" CFLAGS="$CFLAGS -DHAVE_CONFIG_H" +CFLAGS="$CFLAGS `pcre-config --cflags`" -for i in ../src/tup/*.c ../src/tup/tup/main.c ../src/tup/monitor/null.c ../src/tup/flock/fcntl.c ../src/inih/ini.c ../src/pcre/*.c $plat_files; do +for i in ../src/tup/*.c ../src/tup/tup/main.c ../src/tup/monitor/null.c ../src/tup/flock/fcntl.c ../src/inih/ini.c $plat_files; do echo " bootstrap CC $CFLAGS $i" # Put -I. first so we find our new luabuiltin.h file, not one built # by a previous 'tup upd'. - $CC $CFLAGS -c $i -I. -I../src -I../src/pcre $plat_cflags + $CC $CFLAGS -c $i -I. -I../src $plat_cflags done -echo " bootstrap CC $CFLAGS ../src/sqlite3/sqlite3.c" -$CC $CFLAGS -c ../src/sqlite3/sqlite3.c -DSQLITE_TEMP_STORE=2 -DSQLITE_THREADSAFE=0 -DSQLITE_OMIT_LOAD_EXTENSION $plat_cflags - echo " bootstrap LD tup $LDFLAGS" echo "const char *tup_version(void) {return \"$label\";}" | $CC -x c -c - -o tup_version.o $CC *.o -o tup -lpthread $plat_ldflags $LDFLAGS diff --git a/src/tup/db.c b/src/tup/db.c index 55ee3edd..9bdf7a80 100644 --- a/src/tup/db.c +++ b/src/tup/db.c @@ -46,7 +46,7 @@ #include #include #include -#include "sqlite3/sqlite3.h" +#include #define DB_VERSION 17 #define PARSER_VERSION 12 diff --git a/src/tup/tupid.h b/src/tup/tupid.h index 7b36ae46..19aed438 100644 --- a/src/tup/tupid.h +++ b/src/tup/tupid.h @@ -21,7 +21,7 @@ #ifndef tup_tupid_h #define tup_tupid_h -#include "sqlite3/sqlite3.h" +#include typedef sqlite3_int64 tupid_t; -- 2.26.2 'search' size='10' name='q' value=''/>
AgeCommit message (Collapse)Author
2024-09-09system: locale: ‘glibc-supported-locales’ uses zstd instead of xz.Ludovic Courtès
This is a followup to c9666c120b8e40321d6044f572533e160c1e0351. Fixes <https://issues.guix.gnu.org/73065>. * gnu/system/locale.scm (glibc-supported-locales): Change XZ to ZSTD. Change-Id: Ie3cb5d50648a0698ce5246591fb405e4eb690af5
2024-08-31gnu: %default-locale-libcs: Add glibc-2.35 and generalize for Hurd.Josselin Poiret
* gnu/system/locale.scm (%default-locale-libcs): Stop checking for Hurd, since we have the same libc now. Also add glibc-2.35 while the transition happens. Change-Id: I1f4980d18184580f3a42a86ca244c8015df15269
2024-04-29locale: Shrink ‘%default-locale-definitions’ from 34 to 10 locales.Ludovic Courtès
This reduces the default set of locales from 92 MiB to 28 MiB. * gnu/system/locale.scm (%default-locale-definitions): Reduce to 10 locales. Change-Id: I3c092604301d69db591957bcfd62a062c3ac5ab0
2024-04-29system: Remove ‘glibc-2.33’ from ‘%default-locale-libcs’.Ludovic Courtès
The transition from glibc 2.33 to 2.35 was done in c919bfefd98bf2e29549539b4e28e6dc2a8a6f32 (one year ago), so we can assume that the backward-compatible locales are no longer needed by default. This removes 92 MiB from the system closure. * gnu/system/locale.scm (%default-locale-libcs): Remove GLIBC-2.33. Change-Id: I85948bbe6b2d424f9f158eeafdb5543688c66c6b
2023-09-16locale: Set %default-locale-definitions to glibc/hurd on the Hurd.Janneke Nieuwenhuizen
* gnu/system/locale.scm (%default-locale-libcs): Use only glib/hurd when building on the Hurd.
2023-04-19locale: Add glibc 2.33 to '%default-locale-libcs'.Ludovic Courtès
Fixes <https://issues.guix.gnu.org/62934>. Reported by Brian Cully <bjc@spork.org>. * gnu/system/locale.scm (%default-locale-libcs): Add GLIBC-2.33.
2022-01-14system: locale: Use only the current glibc.Mathieu Othacehe
* gnu/system/locale.scm (%default-locale-libcs): Remove glibc-2.31.