Make trytond add all paths listed in GUIX_TRYTOND_MODULES_PATH to sys.path. *** a/trytond/modules/__init__.py 1970-01-01 01:00:01.000000000 +0100 --- b/trytond/modules/__init__.py 2021-12-02 22:17:28.014612267 +0100 *************** *** 31,36 **** --- 31,48 ---- EGG_MODULES = {} + def __extend_python_path__(): + tryton_python_path = os.environ.get("GUIX_TRYTOND_MODULES_PATH") + if tryton_python_path: + paths = [path[:-16] # remove "/trytond/modules" + for path in tryton_python_path.split(os.pathsep)] + sys.path.extend(paths) + # ensure new paths are in the pkg_resources WorkingSet + import pkg_resources + list(map(pkg_resources.working_set.add_entry, paths)) + + __extend_python_path__() + def update_egg_modules(): global EGG_MODULES l Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/texinfo.scm
AgeCommit message (Expand)Author
2023-01-30gnu: texinfo: Make 'perl-archive-zip' available to 'texi2any'....This makes "texi2any --epub3" work out of the box. Reported by BitPuffin on #guile. * gnu/packages/texinfo.scm (texinfo-7)[inputs, arguments]: New fields. Ludovic Courtès
2023-01-25gnu: texinfo: Update to 7.0.2....* gnu/packages/texinfo.scm (texinfo-7): Update to 7.0.2. Ludovic Courtès
2022-12-12Merge branch 'version-1.4.0'Ludovic Courtès
2022-12-06gnu: texinfo, info-reader: Do not run tests when cross-compiling....Fixes a regression introduced in a3264f31df9774ea514e18ed8e7b6bcb44061edc. Reported by Mathieu Othacehe <othacehe@gnu.org>. * gnu/packages/texinfo.scm (texinfo)[arguments]: Change #:tests? to not run tests when cross-compiling. Ludovic Courtès
2022-11-28gnu: texinfo: Disable tests on GNU/Hurd....* gnu/packages/texinfo.scm (texinfo)[arguments]: Add #:tests? argument. Ludovic Courtès
2022-11-30gnu: texinfo-7: Update to 7.0.1....* gnu/packages/texinfo.scm (texinfo-7): Update to 7.0.1. Efraim Flashner
2022-11-28gnu: texinfo: Disable tests on GNU/Hurd....* gnu/packages/texinfo.scm (texinfo)[arguments]: Add #:tests? argument. Ludovic Courtès
2022-11-09gnu: texinfo: Add version 7.0....* gnu/packages/texinfo.scm (texinfo-7): New variable. Ludovic Courtès