Work around trytond.module not being a real namespace module.
Solution is to add all trytond module's locations to
trytond.modules._path__. This will make trytond.module behave much
like a namespace module.
Adding to __path__ is done in update_egg_modules() to ensure __path__
is updated whenever the list of egg modules is updated.
*** a/trytond/modules/__init__.py 1970-01-01 01:00:01.000000000 +0100
--- b/trytond/modules/__init__.py 2021-12-02 18:12:15.385101986 +0100
***************
*** 38,43 ****
--- 38,46 ----
import pkg_resources
for ep in pkg_resources.iter_entry_points('trytond.modules'):
EGG_MODULES[ep.name] = ep
+ path = os.path.join(ep.dist.location, 'trytond', 'modules')
+ if not path in __path__ and os.path.isdir(path):
+ __path__.append(path)
except ImportError:
pass
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2023-07-20 | Revert "gnu: libunistring: Fix make check for the Hurd."...This reverts commit 12e6a5923812abf180f03bea9e07dd99244a3fcd, which used
XFAIL_TESTS to have 'make check' pass with failing tests "test-perror2"
"test-strerror_r" that now pass with glibc-2.37 and libc-for-target in
commencement.
| Janneke Nieuwenhuizen |
2023-05-31 | gnu: libunistring: Fix make check for the Hurd....* gnu/packages/libunistring.scm (libunistring)[arguments]: Set XFAIL_TESTS
with test-perror2, and test-strerror_r when building to the Hurd.
| Janneke Nieuwenhuizen |
2022-05-28 | gnu: libunistring: Rewrite using gexps....* gnu/packages/libunistring.scm (libunistring)[arguments]: Rewrite using
gexps. Remove trailing #t.
| Efraim Flashner |
2022-05-28 | gnu: libunistring: Update to 1.0....* gnu/packages/libunistring.scm (libunistring): Update to 1.0.
[license]: Update in accordance with upstream.
| Efraim Flashner |