This patch modifies Transmission so it honors the "localedir" option passed to its configure script, allowing GTK-specific localization data to be placed in the package's "gui" output. Without this patch, localization of transmission-gtk can break as the application will expect to find this data in the package's default output (as a result of the call to bindtextdomain in gtk/main.c). diff --git a/configure b/configure index a29e24f..3ae8ef4 100755 --- a/configure +++ b/configure @@ -21305,7 +21305,7 @@ $as_echo "$LINGUAS" >&6; } sed -e "/^#/d" -e "/^\$/d" -e "s,.*, $posrcprefix& \\\\," -e "\$s/\(.*\) \\\\/\1/" \ < $srcdir/po/POTFILES.in > po/POTFILES - transmissionlocaledir='${prefix}/${DATADIRNAME}/locale' + transmissionlocaledir='${localedir}' fi diff --git a/configure.ac b/configure.ac index 57d3cae..ab62093 100644 --- a/configure.ac +++ b/configure.ac @@ -563,7 +563,7 @@ if test "x$enable_nls" = "xyes" ; then AC_SUBST(GETTEXT_PACKAGE) AC_DEFINE_UNQUOTED([GETTEXT_PACKAGE],["$GETTEXT_PACKAGE"],[Gettext package]) AM_GLIB_GNU_GETTEXT - transmissionlocaledir='${prefix}/${DATADIRNAME}/locale' + transmissionlocaledir='${localedir}' AC_SUBST(transmissionlocaledir) fi AC_SUBST(INTLLIBS) d03ef483b948ed7'>treecommitdiff
path: root/.dir-locals.el
AgeCommit message (Expand)Author
2020-12-15system: 'init' does not recompute the hash of each store item....Ludovic Courtès
2020-11-17Merge remote-tracking branch 'origin/version-1.2.0' into master...Maxim Cournoyer
2020-11-16.dir-locals.el: Add upstream report link....Miguel Ángel Arruga Vivas
2020-11-16.dir-locals.el: Use setq-local on guix-directory....Christopher Lemmer Webber
2020-11-16.dir-locals.el: Prevent errors if .dir-locals.el isn't found....Christopher Lemmer Webber
2020-11-12maint: update-guix-package: Optionally add sources to store....Maxim Cournoyer
2020-11-01.dir-locals.el: Require cl-lib at runtime....Miguel Ángel Arruga Vivas
2020-10-31.dir-locals.el: Automatically set the GEISER-GUILE-LOAD-PATH variable....Maxim Cournoyer
2020-10-19maint: update-guix-package: Prevent accidentally breaking guix pull....Maxim Cournoyer
2020-09-14deduplication: pass store directory to replace-with-link....Caleb Ristvedt
2020-09-14.dir-locals.el: fix call-with-{retrying-}transaction indenting....Caleb Ristvedt
2020-08-26.dir-locals.el: Add indentation rule for 'package/inherit'....Ludovic Courtès
2020-06-25deduplication: Use 'dynamic-wind' when changing permissions of the parent....Ludovic Courtès