Fix the build with gtkmm 4: https://github.com/transmission/transmission/issues/6392 Patch copied from upstream source repository: https://github.com/transmission/transmission/commit/e116672b27b314d54514c96b1fa7aef1dee900b1 From e116672b27b314d54514c96b1fa7aef1dee900b1 Mon Sep 17 00:00:00 2001 From: =?UTF-8?q?C=C5=93ur?= Date: Sun, 17 Dec 2023 16:37:35 +0100 Subject: [PATCH] fix: build error on GTKMM-4 (#6393) --- gtk/OptionsDialog.cc | 11 ++++++++++- 1 file changed, 10 insertions(+), 1 deletion(-) diff --git a/gtk/OptionsDialog.cc b/gtk/OptionsDialog.cc index 08198540c10..8c28fc76f98 100644 --- a/gtk/OptionsDialog.cc +++ b/gtk/OptionsDialog.cc @@ -338,7 +338,16 @@ void TorrentFileChooserDialog::onOpenDialogResponse(int response, Glib::RefPtr>(); + auto files_model = get_files(); + for (auto i = guint{ 0 }; i < files_model->get_n_items(); ++i) + { + files.push_back(gtr_ptr_dynamic_cast(files_model->get_object(i))); + } +#else + auto const files = get_files(); +#endif g_assert(!files.empty()); /* remember this folder the next time we use this dialog */ cookbook.de.po?id=fbff88da7f6178a11ccd5f08c0c0927480255f2d'>diff
AgeCommit message (Expand)Author
2024-06-03nls: Update translations....Florian Pelz
2024-05-01nls: Update translations....Florian Pelz
2024-04-01nls: Update translations....Florian Pelz
2024-02-29nls: Update translations....Florian Pelz
2024-02-01nls: Update translations....Florian Pelz
2024-01-01nls: Update translations....Florian Pelz
2023-10-31nls: Update translations....Florian Pelz
2023-08-31nls: Update translations.Florian Pelz
2023-06-30nls: Update translations....Florian Pelz
2023-05-31nls: Update translations....Florian Pelz
2023-03-07nls: Update translations.Julien Lepiller