Fix the build with gtkmm 4: https://github.com/transmission/transmission/issues/6392 Patch copied from upstream source repository: https://github.com/transmission/transmission/commit/e116672b27b314d54514c96b1fa7aef1dee900b1 From e116672b27b314d54514c96b1fa7aef1dee900b1 Mon Sep 17 00:00:00 2001 From: =?UTF-8?q?C=C5=93ur?= Date: Sun, 17 Dec 2023 16:37:35 +0100 Subject: [PATCH] fix: build error on GTKMM-4 (#6393) --- gtk/OptionsDialog.cc | 11 ++++++++++- 1 file changed, 10 insertions(+), 1 deletion(-) diff --git a/gtk/OptionsDialog.cc b/gtk/OptionsDialog.cc index 08198540c10..8c28fc76f98 100644 --- a/gtk/OptionsDialog.cc +++ b/gtk/OptionsDialog.cc @@ -338,7 +338,16 @@ void TorrentFileChooserDialog::onOpenDialogResponse(int response, Glib::RefPtr>(); + auto files_model = get_files(); + for (auto i = guint{ 0 }; i < files_model->get_n_items(); ++i) + { + files.push_back(gtr_ptr_dynamic_cast(files_model->get_object(i))); + } +#else + auto const files = get_files(); +#endif g_assert(!files.empty()); /* remember this folder the next time we use this dialog */ /guix/diff/gnu/packages/bison.scm?id=ee0ef0b58ff3ba4b6b2aa81246a50ab9bf020292'>diff
AgeCommit message (Expand)Author
2021-12-13gnu: Simplify package inputs.Ludovic Courtès
2021-05-09gnu: bison: Update to 3.7.6.Marius Bakke
2021-01-26gnu: bison: Update to 3.7.5.Efraim Flashner
2020-11-18gnu: bison: Update to 3.7.4.Efraim Flashner
2020-08-26Merge remote-tracking branch 'origin/master' into core-updatesMathieu Othacehe
2020-07-30gnu: bison: Mention yacc in the description.Jakub Kądziołka
2020-06-22gnu: bison-3.6: Remove package.Jakub Kądziołka
2020-06-22Merge branch 'master' into core-updatesJakub Kądziołka
2020-06-22gnu: bison-3.6: Don't change the name of the package.Jakub Kądziołka
2020-06-21gnu: Add poke.B. Wilson
2020-06-21gnu: bison: Update to 3.6.3.B. Wilson
2020-03-26gnu: bison: Update to 3.5.3.Marius Bakke
2020-02-15gnu: bison: Update to 3.5.2.Marius Bakke
2020-01-24gnu: bison: Update to 3.5.1.Marius Bakke
2019-12-16gnu: bison: Update to 3.5.Efraim Flashner
2019-11-26gnu: bison: Update to 3.4.2.Efraim Flashner
2019-09-30gnu: xyce: Use Bison 3.0.Ludovic Courtès
2019-06-17gnu: bison: Disable parallel tests, too.Marius Bakke
2019-06-16gnu: bison: Disable parallel build.Marius Bakke
2019-05-25gnu: bison: Update to 3.4.1.Marius Bakke