Fixes "multiple definition" errors when building with GCC 10+. Based on . --- a/fig2dev/dev/gensvg.c 2010-07-01 22:41:16.000000000 +0200 +++ b/fig2dev/dev/gensvg.c 2022-02-27 20:02:33.379945500 +0100 @@ -230,10 +230,12 @@ }; /* arrowhead arrays */ -Point points[50], fillpoints[50], clippoints[50]; -int npoints, nfillpoints, nclippoints; -int arrowx1, arrowy1; /* first point of object */ -int arrowx2, arrowy2; /* second point of object */ +Point fillpoints[50]; +int nfillpoints; +extern Point points[50], clippoints[50]; +extern int npoints, nclippoints; +extern int arrowx1, arrowy1; /* first point of object */ +extern int arrowx2, arrowy2; /* second point of object */ static int tileno=0; /* number of current tile */ --- a/fig2dev/fig2dev.h 2010-03-16 19:53:20.000000000 +0100 +++ b/fig2dev/fig2dev.h 2022-02-27 19:56:06.072253991 +0100 @@ -126,7 +126,7 @@ extern char *prog, *from, *to; extern char *name; extern double font_size; -Boolean correct_font_size; /* use correct font size */ +extern Boolean correct_font_size; /* use correct font size */ extern double mag, fontmag; extern FILE *tfp; scm'>logtreecommitdiff
path: root/gnu/services/admin.scm
AgeCommit message (Expand)Author
2020-07-27services: Add 'unattended-upgrade-service-type'....Ludovic Courtès
2020-05-06services: rottlog: Append '.gz' to rotated file....Brice Waegeneire
2019-06-15services: Remove unneeded imports that led to cycles....Ludovic Courtès
2018-12-23services: Fix typo in (gnu services admin)....Tobias Geerinckx-Rice
2018-10-04services: rottlog: Use command strings in the mcron jobs....Ludovic Courtès
2018-09-10services: tailon: Move to (gnu services web)....Ludovic Courtès
2018-03-22gnu: shepherd: Update to 0.4.0....Ludovic Courtès
2018-03-22services: rottlog: Add /var/log/debug to '%default-rotations'....Ludovic Courtès
2017-11-05services: Add 'description' fields....Ludovic Courtès
2017-08-09services: admin: Simplify the handling of the Tailon debug? option....Christopher Baines
2017-08-09services: Update the Tailon service for Tailon 1.3.0....Christopher Baines
2017-08-09services: Add missing wrap-lines option to tailon....Christopher Baines
2017-07-29gnu: services: admin: Add tailon....Christopher Baines