From 858ee78fbebe161a4cdd707a469dc0f045211a51 Mon Sep 17 00:00:00 2001 From: Max Harmathy Date: Wed, 25 Aug 2021 13:05:58 +0200 Subject: [PATCH] Use reason_phrase instead of get_phrase --- src/Services/Cache.vala | 2 +- src/Services/Network.vala | 7 +------ 2 files changed, 2 insertions(+), 7 deletions(-) diff --git a/src/Services/Cache.vala b/src/Services/Cache.vala index 2251697..2ed314e 100644 --- a/src/Services/Cache.vala +++ b/src/Services/Cache.vala @@ -88,7 +88,7 @@ public class Tootle.Cache : GLib.Object { try { var code = msg.status_code; if (code != Soup.Status.OK) { - var error = network.describe_error (code); + var error = msg.reason_phrase; throw new Oopsie.INSTANCE (@"Server returned $error"); } diff --git a/src/Services/Network.vala b/src/Services/Network.vala index fa2839c..d0143b0 100644 --- a/src/Services/Network.vala +++ b/src/Services/Network.vala @@ -56,7 +56,7 @@ public class Tootle.Network : GLib.Object { else if (status == Soup.Status.CANCELLED) debug ("Message is cancelled. Ignoring callback invocation."); else - ecb ((int32) status, describe_error ((int32) status)); + ecb ((int32) status, msg.reason_phrase); }); } catch (Error e) { @@ -65,11 +65,6 @@ public class Tootle.Network : GLib.Object { } } - public string describe_error (uint code) { - var reason = Soup.Status.get_phrase (code); - return @"$code: $reason"; - } - public void on_error (int32 code, string message) { warning (message); app.toast (message); lue='committer'>committer
path: root/ROADMAP
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-05-25 17:29:12 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-05-25 19:31:34 +0200
commit3e0190a8502dc16b39e1d11a69f31efdf5b8c412 (patch)
tree5cc073bf29c694280e4a5610815d1872a40171cf /ROADMAP
parentae58ebba8211f3593fb6d7214f5b80bc6aca5929 (diff)
downloadguix-3e0190a8502dc16b39e1d11a69f31efdf5b8c412.tar.gz
guix-3e0190a8502dc16b39e1d11a69f31efdf5b8c412.zip
gnu: redkite: Update to 0.8.1.
* gnu/packages/audio.scm (redkite): Update to 0.8.1.
Diffstat (limited to 'ROADMAP')
0 files changed, 0 insertions, 0 deletions