This patch hard-codes the Tk library directory during package initialization. See . diff --git a/generic/tkWindow.c b/generic/tkWindow.c index b5cbbab..96b5501 100644 --- a/generic/tkWindow.c +++ b/generic/tkWindow.c @@ -988,6 +988,7 @@ TkCreateMainWindow( Tcl_SetVar2(interp, "tk_patchLevel", NULL, TK_PATCH_LEVEL, TCL_GLOBAL_ONLY); Tcl_SetVar2(interp, "tk_version", NULL, TK_VERSION, TCL_GLOBAL_ONLY); + Tcl_SetVar2(interp, "tk_library", NULL, TK_LIBRARY, TCL_GLOBAL_ONLY); tsdPtr->numMainWindows++; return tkwin; diff --git a/unix/Makefile.in b/unix/Makefile.in index f21fdbb..c61b0df 100644 --- a/unix/Makefile.in +++ b/unix/Makefile.in @@ -1029,7 +1029,7 @@ tkVisual.o: $(GENERIC_DIR)/tkVisual.c $(CC) -c $(CC_SWITCHES) $(GENERIC_DIR)/tkVisual.c tkWindow.o: $(GENERIC_DIR)/tkWindow.c - $(CC) -c $(CC_SWITCHES) $(GENERIC_DIR)/tkWindow.c + $(CC) -c $(CC_SWITCHES) -DTK_LIBRARY=\"${TK_LIBRARY}\" $(GENERIC_DIR)/tkWindow.c tkButton.o: $(GENERIC_DIR)/tkButton.c $(CC) -c $(CC_SWITCHES) $(GENERIC_DIR)/tkButton.c 23f4d6'>refslogtreecommitdiff
path: root/m4
AgeCommit message (Expand)Author
2018-06-01build: Check for Guile-SQLite3....Ludovic Courtès
2018-02-26build: Require Guile >= 2.0.13....Ludovic Courtès
2018-01-06build: Detect broken 'equal?' in Guile 2.2.1....Ludovic Courtès
2017-06-30build: Remove check for broken (srfi srfi-37)....Ludovic Courtès
2017-02-20gnu: Add bootstrap-binaries for 'aarch64-linux'....Efraim Flashner
2016-11-25offload: Use Guile-SSH instead of GNU lsh....Ludovic Courtès
2016-08-10build: Correctly determine the system type for GNU/Hurd systems....Manolis Ragkousis
2016-07-20Merge branch 'master' into core-updatesLudovic Courtès
2016-07-19Add (guix zlib)....Ludovic Courtès
2016-06-23build: Remove unneeded conditionals for (guix build syscalls)....Manolis Ragkousis
2016-03-19build: Protect against misconfiguration of localstatedir....Ludovic Courtès
2016-01-13build: Use 127 as the Linux hash-bang limit....Ludovic Courtès
2016-01-12build: 'make check' errors out if file name limits would be hit....Ludovic Courtès
2016-01-12build: Warn against long hash bang lines for tests....Ludovic Courtès
2015-12-01build: Fix detection of ARM systems....Ludovic Courtès
2015-11-25build: Reject ARMv6 systems....Ludovic Courtès
2015-10-09build: Fix libgcrypt detection on FHS systems....Ludovic Courtès
2015-10-06build: Automatically determine libgcrypt's file name....Ludovic Courtès
2015-08-27build: Do not build (guix build syscalls) if 'mount' is missing from libc....Ludovic Courtès