Make test work with upstream cbehave (tinydir bundles a modified version) diff --git a/tests/file_open_test.c b/tests/file_open_test.c index 09b856e..92b13ca 100644 --- a/tests/file_open_test.c +++ b/tests/file_open_test.c @@ -4,6 +4,11 @@ #include "cbehave.h" #include "util.h" +#define ASSERT(cond, ret) \ +if (!(cond)) {\ + cbehave_feature_return(__FILE__, __LINE__, ret, _state); \ + goto _feature_over; \ +}\ FEATURE(file_open, "File open") SCENARIO("Open file in current directory") @@ -34,4 +39,7 @@ FEATURE(file_open, "File open") SCENARIO_END FEATURE_END -CBEHAVE_RUN("File open:", TEST_FEATURE(file_open)) +int main(void) { + cbehave_feature _cfeatures[] = {{feature_idx(file_open)}}; + return cbehave_runner("File open:", _cfeatures); +} alue='koszko-scripts'>koszko-scripts Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/machine
AgeCommit message (Expand)Author
2022-11-17machine: ssh: Validate 'system' field....Ludovic Courtès
2022-11-09machine/digital-ocean: Pull operating system definition out of string....Ricardo Wurmus
2022-11-09machine/digital-ocean: Set load path to Guile 3.0 directories....Ricardo Wurmus
2022-11-09machine/digital-ocean: Use static-networking-service-type....Ricardo Wurmus
2022-11-09machine/digital-ocean: Use nightly Guix....Ricardo Wurmus
2022-10-17guix: Fix typos....Julien Lepiller
2022-09-26machine: ssh: Parameterize '%current-system' early on....Ludovic Courtès
2022-09-04Fix misspelling of GUIX_DIGITAL_OCEAN_TOKEN....Matthew James Kraai
2022-03-01initrd: Use non-hyphenated kernel command-line parameter names....Maxim Cournoyer
2022-01-16machine: ssh: Add 'safety-checks?' field....Ludovic Courtès
2022-01-09machine: ssh: Open a single SSH session per machine....Ludovic Courtès
2021-08-29Migrate to the new 'targets' field of bootloader-configuration....Maxim Cournoyer
2021-06-20services: openssh: Replace 'without-password' by 'prohibit-password'....Brice Waegeneire
2021-06-03machine: ssh: Respect calling convention for monadic procedures....Ludovic Courtès
2021-06-01machine: ssh: Gracefully handle failure of the effectful bits....Ludovic Courtès