Make test work with upstream cbehave
(tinydir bundles a modified version)
diff --git a/tests/file_open_test.c b/tests/file_open_test.c
index 3e659bc..9f6f88d 100644
--- a/tests/file_open_test.c
+++ b/tests/file_open_test.c
@@ -19,4 +19,7 @@ FEATURE(file_open, "File open")
SCENARIO_END
FEATURE_END
-CBEHAVE_RUN("File open:", TEST_FEATURE(file_open))
+int main(void) {
+ cbehave_feature _cfeatures[] = {{feature_idx(file_open)}};
+ return cbehave_runner("File open:", _cfeatures);
+}
>
index : guix | |
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2023-03-07 | nls: Update translations. | Julien Lepiller |
2023-01-05 | nls: Update translations....* po/guix/ka.po: New file.
* po/guix/LINGUAS: Add it.
* po/packages/uk.po: New file.
* po/packages/LINGUAS: Add it.
| Julien Lepiller |
2022-12-15 | doc: Use VM image file name consistently....Previously, what "/tmp/qemu-image" refers to could be unclear at first.
* doc/guix.texi (Running Guix in a VM): Use the original image file
name instead of /tmp/qemu-image.
* po/doc/guix-manual.de.po, po/doc/guix-manual.es.po,
po/doc/guix-manual.fr.po, po/doc/guix-manual.pt_BR.po,
po/doc/guix-manual.ru.po, po/doc/guix-manual.zh_CN.po: Adjust
accordingly.
| Ludovic Courtès |
2022-12-04 | nls: Update translations....po/packages/vi.po: New file.
po/packages/LINGUAS: Add it.
| Julien Lepiller |
2022-11-04 | nls: Update translations....* po/guix/lt.po: New file.
* po/guix/LINGUAS: Add lt.
| Julien Lepiller |