Make test work with upstream cbehave
(tinydir bundles a modified version)
diff --git a/tests/file_open_test.c b/tests/file_open_test.c
index 3e659bc..9f6f88d 100644
--- a/tests/file_open_test.c
+++ b/tests/file_open_test.c
@@ -19,4 +19,7 @@ FEATURE(file_open, "File open")
SCENARIO_END
FEATURE_END
-CBEHAVE_RUN("File open:", TEST_FEATURE(file_open))
+int main(void) {
+ cbehave_feature _cfeatures[] = {{feature_idx(file_open)}};
+ return cbehave_runner("File open:", _cfeatures);
+}
/a>
index : guix | |
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2021-12-13 | gnu: Simplify package inputs....This commit was obtained by running:
./pre-inst-env guix style
without any additional argument.
| Ludovic Courtès |
2021-10-06 | gnu: quazip: Update to 1.1....* gnu/packages/compression.scm (quazip): Redefine as an heir to the…
(quazip-0): …new name of the previous package definition.
Adjust all packages with quazip as input to use quazip-0.
| Tobias Geerinckx-Rice |