Make test work with upstream cbehave
(tinydir bundles a modified version)
diff --git a/tests/file_open_test.c b/tests/file_open_test.c
index 3e659bc..9f6f88d 100644
--- a/tests/file_open_test.c
+++ b/tests/file_open_test.c
@@ -19,4 +19,7 @@ FEATURE(file_open, "File open")
SCENARIO_END
FEATURE_END
-CBEHAVE_RUN("File open:", TEST_FEATURE(file_open))
+int main(void) {
+ cbehave_feature _cfeatures[] = {{feature_idx(file_open)}};
+ return cbehave_runner("File open:", _cfeatures);
+}
ss='main'>index : guix
|
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2021-12-13 | gnu: Simplify package inputs....This commit was obtained by running:
./pre-inst-env guix style
without any additional argument.
| Ludovic Courtès |
2020-10-27 | gnu: nvi: Add missing includes....This is a follow-up of a01f32924423c45a0ffa50f6c1727be2a25ef75c.
* gnu/packages/nvi.scm (nvi): Add missing includes.
| Mathieu Othacehe |
2020-10-27 | gnu: nvi: Fix cross-compilation....* gnu/packages/nvi.scm (nvi)[arguments]: Add "vi_cv_sprintf_count=yes" to
configure flags when cross-compiling. Also add 'fix-configure phase.
[native-inputs]: Add "automake" that is required by the new phase.
| Mathieu Othacehe |