Copied from Debian. From c18f27a58792f7fbd0b30a0ff50d6b40a82f940d Mon Sep 17 00:00:00 2001 From: Geoff McLane Date: Wed, 3 Jun 2015 20:26:03 +0200 Subject: [PATCH] Issue #217 - avoid len going negative, ever... --- src/lexer.c | 8 +++++--- 1 file changed, 5 insertions(+), 3 deletions(-) diff --git a/src/lexer.c b/src/lexer.c index 376a3d8..664f806 100644 --- a/src/lexer.c +++ b/src/lexer.c @@ -3739,16 +3740,17 @@ static tmbstr ParseValue( TidyDocImpl* doc, ctmbstr name, /* and prompts attributes unless --literal-attributes is set to yes */ /* #994841 - Whitespace is removed from value attributes */ - if (munge && + /* Issue #217 - Also only if/while (len > 0) - MUST NEVER GO NEGATIVE! */ + if ((len > 0) && munge && TY_(tmbstrcasecmp)(name, "alt") && TY_(tmbstrcasecmp)(name, "title") && TY_(tmbstrcasecmp)(name, "value") && TY_(tmbstrcasecmp)(name, "prompt")) { - while (TY_(IsWhite)(lexer->lexbuf[start+len-1])) + while (TY_(IsWhite)(lexer->lexbuf[start+len-1]) && (len > 0)) --len; - while (TY_(IsWhite)(lexer->lexbuf[start]) && start < len) + while (TY_(IsWhite)(lexer->lexbuf[start]) && (start < len) && (len > 0)) { ++start; --len; /cache.scm?id=6ed5b496bc1a2199fe5d40b5186df38789ff6937'>diff
path: root/tests/cache.scm
2:07 +0100'>2020-01-17
AgeCommit message (Expand)Author
2022-06-04cache: Catch invalid 'last-expiry-cleanup'....zimoun
2020-03-22Remove workaround for 'time-monotonic' in Guile 2.2.2....Ludovic Courtès
import: opam: Avoid uses of '@@' in tests....Ludovic Courtès
2019-09-07tests: opam: Fix input type in import test....Julien Lepiller
2019-02-05import: opam: Fix conditions....Julien Lepiller
2018-12-17import: Update opam importer....Julien Lepiller
2018-09-04Switch to Guile-Gcrypt....Ludovic Courtès
2018-07-10guix: Add opam importer....Julien Lepiller