Retain environment setting of "HOME" for tests that need os.path.expanduser() to return a readable directory in the build chroot. --- thefuck-3.25/tests/conftest.py +++ thefuck-3.25/tests/conftest.py @@ -64,6 +64,7 @@ def set_shell(monkeypatch): @pytest.fixture(autouse=True) def os_environ(monkeypatch): - env = {'PATH': os.environ['PATH']} + env = {'PATH': os.environ['PATH'], + 'HOME': os.environ['HOME']} monkeypatch.setattr('os.environ', env) return env -static/cgit.png' alt='cgit logo'/> index : guix
Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/sync.scm
AgeCommit message (Expand)Author
2023-09-24gnu: onedrive: Update to 2.4.25.Tobias Geerinckx-Rice
2023-09-17gnu: Remove extraneous imports.Maxim Cournoyer
2023-07-23gnu: fuse@3: Bind to default FUSE variable.Tobias Geerinckx-Rice
2023-07-02gnu: nextcloud-client: Update to 3.8.2.Hartmut Goebel
2023-06-14gnu: onedrive: Link to all necessary libraries.Efraim Flashner
2023-04-07gnu: curl-minimal: Remove variable.Bruno Victal
2023-02-04gnu: megacmd: Update to 1.5.1 and add libuv dependency.Wamm K. D