Description: Avoid dependency on byebug to reduce package closure
significantly, see https://issues.guix.gnu.org/55997
diff --git a/lib/tex/hyphen/language.rb b/lib/tex/hyphen/language.rb
index 12831417..df6daa39 100644
--- a/lib/tex/hyphen/language.rb
+++ b/lib/tex/hyphen/language.rb
@@ -1,6 +1,5 @@
require 'yaml'
require 'hydra'
-require 'byebug'
require_relative 'path'
index : guix | |
Wojtek's customized Guix | |
Age | Commit message (Collapse) | Author |
|
Also ensure prompt_yes_no always print the message with a trailing space,
which is more pleasing to the eye.
* etc/guix-daemon.conf.in <--discover=no>: New guix-daemon option.
* etc/guix-daemon.service.in: Likewise.
* etc/init.d/guix-daemon.in: Likewise.
* etc/openrc/guix-daemon.in: Likewise.
* etc/guix-install.sh (configure_substitute_discovery): New procedure.
(sys_enable_guix_daemon): Ask the user whether automatic substitute discovery
should be enabled. Set the '--discover' argument accordingly.
(prompt_yes_no): Add a trailing space to the message.
(sys_authorize_build_farms): Remove trailing space from the message argument.
* NEWS (Distribution): Add news.
|
|
* etc/guix-install.sh (chk_init_sys): Detect OpenRC.
(sys_enable_guix_daemon): Install & enable the Guix daemon on such
systems.
* etc/openrc/guix-daemon.in: New file.
* nix/local.mk: Add a rule for it.
(openrcservicedir, nodist_openrcservice_DATA): New variables.
(CLEANFILES, EXTRA_DIST): Add them.
* .gitignore: Ignore etc/openrc/guix-daemon.
Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
|