Fix a deprecation warning with newer Perl that breaks some tests. --- a/tp/Texinfo/Parser.pm +++ b/tp/Texinfo/Parser.pm @@ -5438,12 +5438,12 @@ } } elsif ($command eq 'clickstyle') { # REMACRO - if ($line =~ /^\s+@([[:alnum:]][[:alnum:]\-]*)({})?\s*/) { + if ($line =~ /^\s+@([[:alnum:]][[:alnum:]\-]*)(\{})?\s*/) { $args = ['@'.$1]; $self->{'clickstyle'} = $1 unless(_ignore_global_commands($self)); $remaining = $line; - $remaining =~ s/^\s+@([[:alnum:]][[:alnum:]\-]*)({})?\s*(\@(c|comment)((\@|\s+).*)?)?//; + $remaining =~ s/^\s+@([[:alnum:]][[:alnum:]\-]*)(\{})?\s*(\@(c|comment)((\@|\s+).*)?)?//; $has_comment = 1 if (defined($4)); } else { $self->line_error (sprintf($self->__( ='selected'>koszko Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/services/certbot.scm
AgeCommit message (Expand)Author
2018-04-03services: certbot: Don't try to renew certificates on activation....Clément Lassieur
2018-03-20Correct name and Email for ng0....ng0
2018-02-22services: certbot: Allow to set a deploy hook....Clément Lassieur
2018-02-22services: certbot: Add verbosity....Clément Lassieur
2018-02-22services: certbot: Allow to set RSA key size....Clément Lassieur
2018-02-22services: certbot: Associate one certificate with several domains....Clément Lassieur
2018-02-22services: certbot: Get certbot to run non-interactively....Clément Lassieur
2018-02-22services: certbot: Refactor certbot command....Clément Lassieur
2018-02-22services: certbot: Rename 'host' to 'domain'....Clément Lassieur
2018-02-22services: certbot: Fix indentation....Clément Lassieur
2018-02-22services: certbot: Run certbot twice a day at a random minute....Clément Lassieur
2018-02-22services: certbot: Listen on IPv6....Clément Lassieur
2017-12-18services: nginx: Replace 'http-port' and 'https-port' with 'listen'....Clément Lassieur
2017-12-17services: certbot: Fix certbot renewal job....Christopher Baines
2017-11-28services: certbot: Add default value and description....Ludovic Courtès
2017-11-28services: Add certbot service....Andy Wingo