Do not try to regenerate po files; use the reference files that are packaged in the tarball. --- a/Makefile.in 2010-06-30 17:02:28.000000000 -0500 +++ b/Makefile.in 2014-08-16 00:22:38.447050269 -0500 @@ -1022,15 +1022,7 @@ i18n/en.thl i18n/: $(po_document_dir)/po_document/$(PACKAGE)_document.pot $(MKDIR_P) i18n - if test '$(USE_NLS)' = 'yes'; then \ - for file in "$(srcdir)/$(po_document_dir)/po_document/"*".po"; do lang=`basename "$$file" .po | sed 's/\..*//'`; \ - test "$$lang" = 'en' && continue; \ - msgexec -i "$$file" "$(srcdir)/gettext_to_separated.pl" | "$(srcdir)/separated_to_hash.pl" $$lang > i18n/$$lang.thl; \ - done; \ - msgexec -i $< "$(srcdir)/gettext_to_separated.pl" | "$(srcdir)/separated_to_hash.pl" en > i18n/en.thl; \ - else \ - cp -p i18n_ref/*.thl i18n; \ - fi + cp -p i18n_ref/*.thl i18n i18n_ref: $(MKDIR_P) i18n_ref Have install-sh install .mo files locally for in-source tests, so that msgfmt is not needed. --- a/Makefile.in 2010-06-30 17:02:28.000000000 -0500 +++ b/Makefile.in 2014-08-16 00:22:38.447050269 -0500 @@ -1052,19 +1044,8 @@ # update the po files, and install locally the .mo files for the in # source tests check-local: makeinfo.pl texi2any.pl - if test '$(USE_NLS)' = 'yes'; then \ - cd $(po_document_dir)/po_document && $(MAKE) $(AM_MAKEFLAGS) update-po; \ - fi - rm -rf locales - for file in "$(srcdir)/$(po_document_dir)/po_document/"*.po; do \ - basename=`basename "$$file" .po` ; \ - $(MKDIR_P) "locales/$$basename/LC_MESSAGES/" ; \ - if test '$(USE_NLS)' = 'yes'; then \ - $(MSGFMT) "$$file" -o "locales/$$basename/LC_MESSAGES/texi2html_document.mo" ; \ - else \ - cp -p "$(srcdir)/$(po_document_dir)/po_document/$$basename.mo" "locales/$$basename/LC_MESSAGES/texi2html_document.mo" ; \ - fi; \ - done + $(MAKE) -C po_document localedir="$(abs_srcdir)/locales" install-data + $(MAKE) -C po_messages localedir="$(abs_srcdir)/locales" install-data makeinfo.pl texi2any.pl: -$(LN_S) $(srcdir)/texi2html.pl $@ e7ad5ce1ee51bb81081b5d948ce9059fa0a9eb'>root/gnu/image.scm
AgeCommit message (Expand)Author
2022-09-24system: image: Add wsl2 support....Alex Griffin
2022-09-24system: image: Add tarball support....Alex Griffin
2022-09-24image: Make the operating-system field mandatory....Mathieu Othacehe
2022-09-07image: Use #true and #false....Mathieu Othacehe
2022-09-07image: Use a default size partition value....Mathieu Othacehe
2022-08-31image: Add comments....Mathieu Othacehe
2022-08-30image: Remove an unused field....Mathieu Othacehe
2022-08-30image: Perform more sanitizing....Mathieu Othacehe
2022-07-01image: Add sanitizers for 'format' and 'partition-table-type'....Ludovic Courtès
2022-07-01image: Add default value for partition initializer....Ludovic Courtès
2022-05-25Move (gnu platform) and (gnu platforms ...) to guix/....Josselin Poiret
2021-12-23image: Add a shared-network? field....Mathieu Othacehe
2021-12-23image: Add a shared-store? field....Mathieu Othacehe
2021-11-12image: Support generating GPT images via `partition-table-type`....Ryan Sundberg
2021-10-11gnu: Add platform support....Mathieu Othacehe
2021-02-17image: Export image? procedure....Mathieu Othacehe