Do not try to regenerate po files; use the reference files that are packaged
in the tarball.
--- a/Makefile.in 2010-06-30 17:02:28.000000000 -0500
+++ b/Makefile.in 2014-08-16 00:22:38.447050269 -0500
@@ -1022,15 +1022,7 @@
i18n/en.thl i18n/: $(po_document_dir)/po_document/$(PACKAGE)_document.pot
$(MKDIR_P) i18n
- if test '$(USE_NLS)' = 'yes'; then \
- for file in "$(srcdir)/$(po_document_dir)/po_document/"*".po"; do lang=`basename "$$file" .po | sed 's/\..*//'`; \
- test "$$lang" = 'en' && continue; \
- msgexec -i "$$file" "$(srcdir)/gettext_to_separated.pl" | "$(srcdir)/separated_to_hash.pl" $$lang > i18n/$$lang.thl; \
- done; \
- msgexec -i $< "$(srcdir)/gettext_to_separated.pl" | "$(srcdir)/separated_to_hash.pl" en > i18n/en.thl; \
- else \
- cp -p i18n_ref/*.thl i18n; \
- fi
+ cp -p i18n_ref/*.thl i18n
i18n_ref:
$(MKDIR_P) i18n_ref
Have install-sh install .mo files locally for in-source tests, so that msgfmt
is not needed.
--- a/Makefile.in 2010-06-30 17:02:28.000000000 -0500
+++ b/Makefile.in 2014-08-16 00:22:38.447050269 -0500
@@ -1052,19 +1044,8 @@
# update the po files, and install locally the .mo files for the in
# source tests
check-local: makeinfo.pl texi2any.pl
- if test '$(USE_NLS)' = 'yes'; then \
- cd $(po_document_dir)/po_document && $(MAKE) $(AM_MAKEFLAGS) update-po; \
- fi
- rm -rf locales
- for file in "$(srcdir)/$(po_document_dir)/po_document/"*.po; do \
- basename=`basename "$$file" .po` ; \
- $(MKDIR_P) "locales/$$basename/LC_MESSAGES/" ; \
- if test '$(USE_NLS)' = 'yes'; then \
- $(MSGFMT) "$$file" -o "locales/$$basename/LC_MESSAGES/texi2html_document.mo" ; \
- else \
- cp -p "$(srcdir)/$(po_document_dir)/po_document/$$basename.mo" "locales/$$basename/LC_MESSAGES/texi2html_document.mo" ; \
- fi; \
- done
+ $(MAKE) -C po_document localedir="$(abs_srcdir)/locales" install-data
+ $(MAKE) -C po_messages localedir="$(abs_srcdir)/locales" install-data
makeinfo.pl texi2any.pl:
-$(LN_S) $(srcdir)/texi2html.pl $@
lue='search'/>
Age | Commit message (Expand) | Author |
2023-10-07 | services: configuration: Add some commonly used predicates....* gnu/services/configuration.scm (list-of-packages?, list-of-symbols?): New
predicate.
* gnu/services/audio.scm (list-of-symbol?): Remove.
* gnu/services/telephony.scm (string-list?): Remove.
(serialize-string-list): Rename to …
(serialize-list-of-strings): … this.
(account-fingerprint-list?, jami-account-list?): Use list-of.
* doc/guix.texi: Update it.
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
| Bruno Victal |
2023-10-07 | services: configuration: Use transducers within serialize-configuration....Introduces 'base-transducer', a SRFI-171 based transducer that can be used as a
starting point for writing custom configuration record serializing procedures.
This also fixes the symbol maybe-value serialization test case.
* gnu/services/configuration.scm (empty-serializer?): New predicate.
(base-transducer, tfilter-maybe-value): New procedure.
(serialize-configuration): Adapt to use base-transducer.
* gnu/services/telephony.scm (jami-account->alist): Use transducers to skip
fields that are unserializable or whose field maybe-value is unset.
* tests/services/configuration.scm: Remove test-expect-fail.
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
| Bruno Victal |
2023-02-08 | gnu: libjami: Move jamid daemon to a "bin" output....* gnu/packages/jami.scm (libjami) [outputs]: Add a "bin" output.
[arguments]: Add a move-jamid phase.
* gnu/services/telephony.scm
(jami-configuration->command-line-arguments): Refer to the "bin" output of
libjami.
(jami-shepherd-services): Likewise.
| Maxim Cournoyer |
2022-09-23 | services: jami-service-type: Streamline stop slot....* gnu/services/telephony.scm (jami-shepherd-services)
[stop]: Use make-kill-destructor with SIGKILL. Add comment.
| Maxim Cournoyer |