Do not try to regenerate po files; use the reference files that are packaged
in the tarball.
--- a/Makefile.in 2010-06-30 17:02:28.000000000 -0500
+++ b/Makefile.in 2014-08-16 00:22:38.447050269 -0500
@@ -1022,15 +1022,7 @@
i18n/en.thl i18n/: $(po_document_dir)/po_document/$(PACKAGE)_document.pot
$(MKDIR_P) i18n
- if test '$(USE_NLS)' = 'yes'; then \
- for file in "$(srcdir)/$(po_document_dir)/po_document/"*".po"; do lang=`basename "$$file" .po | sed 's/\..*//'`; \
- test "$$lang" = 'en' && continue; \
- msgexec -i "$$file" "$(srcdir)/gettext_to_separated.pl" | "$(srcdir)/separated_to_hash.pl" $$lang > i18n/$$lang.thl; \
- done; \
- msgexec -i $< "$(srcdir)/gettext_to_separated.pl" | "$(srcdir)/separated_to_hash.pl" en > i18n/en.thl; \
- else \
- cp -p i18n_ref/*.thl i18n; \
- fi
+ cp -p i18n_ref/*.thl i18n
i18n_ref:
$(MKDIR_P) i18n_ref
Have install-sh install .mo files locally for in-source tests, so that msgfmt
is not needed.
--- a/Makefile.in 2010-06-30 17:02:28.000000000 -0500
+++ b/Makefile.in 2014-08-16 00:22:38.447050269 -0500
@@ -1052,19 +1044,8 @@
# update the po files, and install locally the .mo files for the in
# source tests
check-local: makeinfo.pl texi2any.pl
- if test '$(USE_NLS)' = 'yes'; then \
- cd $(po_document_dir)/po_document && $(MAKE) $(AM_MAKEFLAGS) update-po; \
- fi
- rm -rf locales
- for file in "$(srcdir)/$(po_document_dir)/po_document/"*.po; do \
- basename=`basename "$$file" .po` ; \
- $(MKDIR_P) "locales/$$basename/LC_MESSAGES/" ; \
- if test '$(USE_NLS)' = 'yes'; then \
- $(MSGFMT) "$$file" -o "locales/$$basename/LC_MESSAGES/texi2html_document.mo" ; \
- else \
- cp -p "$(srcdir)/$(po_document_dir)/po_document/$$basename.mo" "locales/$$basename/LC_MESSAGES/texi2html_document.mo" ; \
- fi; \
- done
+ $(MAKE) -C po_document localedir="$(abs_srcdir)/locales" install-data
+ $(MAKE) -C po_messages localedir="$(abs_srcdir)/locales" install-data
makeinfo.pl texi2any.pl:
-$(LN_S) $(srcdir)/texi2html.pl $@
THANKS
Age | Commit message (Expand) | Author |
2016-07-18 | Thank Thomas. | Ricardo Wurmus |
2015-11-23 | Thank Jan. | Ludovic Courtès |
2015-11-17 | Thank Chris. | Ludovic Courtès |
2015-10-09 | Thank Chris. | Ludovic Courtès |
2015-09-20 | Thank Petter. | Ludovic Courtès |
2015-08-27 | Thank Eric Hanchrow. | Ludovic Courtès |
2015-07-23 | Thank Anders. | Ludovic Courtès |
2015-07-22 | Thank Malcolm. | Ludovic Courtès |
2015-07-22 | Thank Dave. | Ludovic Courtès |
2015-07-04 | Clean up 'THANKS' and 'AUTHORS'....* THANKS: Add Konrad Hinsen, Cyprien Nicolas, Yakkala Yagnesh Raghava
and Alexander Shendi. Remove Federico Beffa, Marek Benc, John
Darrington, rekado, Cyrill Schenkel and Andy Wingo because they are
placed in AUTHORS. Move Amirouche Boubekki and Alex Kost to ...
* AUTHORS: ... here. Add Arne Babenhauserheide, Ian Denhardt, Kevin
Lemonnier, Mathieu Lirzin, Pierre-Antoine Rault and Ben Woodcroft.
Fix some names and emails.
| Alex Kost |
2015-06-07 | Thank Thomas. | Ludovic Courtès |