Patch derived from discussion at https://savannah.nongnu.org/bugs/?37503 --- texi2html-5.0/texi2html.pl 2010-06-30 17:01:27.000000000 -0500 +++ texi2html-5.0/texi2html.pl 2014-07-09 01:17:57.062990582 -0500 @@ -2589,7 +2589,12 @@ my $state = shift; # FIXME this should be done only once, for @documentencoding - my $encoding = lc(Texi2HTML::Config::get_conf('DOCUMENT_ENCODING')); + my $encoding; + my $input_encoding = Texi2HTML::Config::get_conf('documentencoding'); + if (defined($input_encoding)) + { + $encoding = lc($input_encoding); + } if (defined($encoding) and $encoding ne '' and exists($Texi2HTML::Config::t2h_encoding_aliases{$encoding})) { $encoding = $Texi2HTML::Config::t2h_encoding_aliases{$encoding}; Fix failures in test/encodings. --- texi2html-5.0/texi2html.pl 2014-07-09 01:22:06.000000000 -0500 +++ texi2html-5.0/texi2html.pl 2014-07-10 23:23:47.182097602 -0500 @@ -53,6 +53,7 @@ # for translations #use encoding 'utf8'; #use utf8; +binmode STDERR, ':encoding(utf8)'; # # According to ?id=3a56a440946b79f00bd3714f912480a6a454531a'>refslogtreecommitdiff
path: root/tests/keys
wrap'>
AgeCommit message (Expand)Author
AgeCommit message (Expand)Author
2019-12-23gnu: clamav: Update to 0.102.1....* gnu/packages/antivirus.scm (clamav): Update to 0.102.1. Tobias Geerinckx-Rice
2019-10-14gnu: clamav: Update to 0.102.0....* gnu/packages/antivirus.scm (clamav): Update to 0.102.0. Eric Bavier
2019-04-11gnu: clamav: Update to 0.101.2....* gnu/packages/antivirus.scm (clamav): Update to 0.101.2. Tobias Geerinckx-Rice
2019-02-24gnu: clamav: Update to 0.101.1....* gnu/packages/antivirus.scm (clamav): Update to 0.101.1. [source]: Delete bundled tomsfastmath outright. [native-inputs]: Remove bison and flex. [inputs]: Switch to pcre2. * gnu/packages/patches/clamav-system-tomsfastmath.patch: Update. Tobias Geerinckx-Rice
2019-01-24gnu: clamav: Unconditionally return #T from build phase....* gnu/packages/antivirus.scm (clamav)[arguments]: Use INVOKE. Ricardo Wurmus
2018-11-17gnu: Add ClamAV....* gnu/packages/antivirus.scm: New file. * gnu/packages/patches/clamav-system-tomsfastmath.patch, gnu/packages/patches/clamav-config-llvm-libs.patch: New files. * gnu/local.mk (GNU_SYSTEM_MODULES): Add new module. (dist_patch_DATA): Add patches. Co-authored-by: Christopher Baines <mail@cbaines.net> Eric Bavier