Patch derived from discussion at https://savannah.nongnu.org/bugs/?37503
--- texi2html-5.0/texi2html.pl 2010-06-30 17:01:27.000000000 -0500
+++ texi2html-5.0/texi2html.pl 2014-07-09 01:17:57.062990582 -0500
@@ -2589,7 +2589,12 @@
my $state = shift;
# FIXME this should be done only once, for @documentencoding
- my $encoding = lc(Texi2HTML::Config::get_conf('DOCUMENT_ENCODING'));
+ my $encoding;
+ my $input_encoding = Texi2HTML::Config::get_conf('documentencoding');
+ if (defined($input_encoding))
+ {
+ $encoding = lc($input_encoding);
+ }
if (defined($encoding) and $encoding ne '' and exists($Texi2HTML::Config::t2h_encoding_aliases{$encoding}))
{
$encoding = $Texi2HTML::Config::t2h_encoding_aliases{$encoding};
Fix failures in test/encodings.
--- texi2html-5.0/texi2html.pl 2014-07-09 01:22:06.000000000 -0500
+++ texi2html-5.0/texi2html.pl 2014-07-10 23:23:47.182097602 -0500
@@ -53,6 +53,7 @@
# for translations
#use encoding 'utf8';
#use utf8;
+binmode STDERR, ':encoding(utf8)';
#
# According to
>summaryrefslogtreecommitdiff
|
Age | Commit message (Expand) | Author |
2021-01-05 | gnu: smalltalk: Update to version 3.2.91....* gnu/packages/smalltalk.scm (smalltalk): Update to 3.2.91.
Co-Authored-By: Holger Peters <holger.peters@posteo.de>
| Miguel Ángel Arruga Vivas |
2021-01-05 | gnu: smalltalk: Fix integer multiplication overflow....* gnu/local.mk (dist_patch_DATA): Add Smalltalk patch.
* gnu/packages/patches/smalltalk-multiplication-overflow.patch: Patch
from upstream commit 72ada189aba0283c551ead16635c1983968080b8.
* gnu/packages/smalltalk.scm (smalltalk): Use patch and link with gmp
and lightning libraries instead of the included source.
| Miguel Ángel Arruga Vivas |
2020-07-25 | gnu: squeak-vm: Enter build directory once....* gnu/packages/smalltalk.scm (squeak-vm)[arguments]: Use CHDIR instead of
pseudofunctional WITH-DIRECTORY-EXCURSIONs. Drop the custom ‘build’ phase.
| Tobias Geerinckx-Rice |
2020-07-25 | gnu: squeak-vm: Update home page....* gnu/packages/smalltalk.scm (squeak-vm)[source, home-page]: Drop ‘www’ subdomain.
| Tobias Geerinckx-Rice |