This test incorrectly expects the libpurple search path to initially contain exactly one element. Remove this incorrect assertion. --- telegram-purple-1.3.1-checkout/test/loadtest.c 2018-10-27 16:25:06.258459600 +0200 +++ telegram-purple-1.3.1-checkout/test/loadtest.c 2018-10-27 16:25:11.830434770 +0200 @@ -156,7 +156,7 @@ static void tdf_inject_plugin (void) { printf ("Injecting our module into purple_plugins_* ...\n"); purple_plugins_init (); GList *search_paths = purple_plugins_get_search_paths (); - assert (!search_paths->prev && !search_paths->next && search_paths->data); + assert (!search_paths->prev && search_paths->data); GList *new_paths = g_list_append (search_paths, g_strdup ("bin/")); assert (new_paths == search_paths); // Load "my" path before the default. koszko-scripts'>koszko-scripts Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/pkg-config.scm
AgeCommit message (Expand)Author
2017-04-13gnu: pkg-config: Update to 0.29.2....Marius Bakke
2017-01-26gnu: pkg-config: Update to 0.29.1....Marius Bakke
2016-02-22gnu: pkg-config: Add non-HTTPS alternate URL....Ludovic Courtès
2016-01-03gnu: pkg-config: Update to 0.29....Ludovic Courtès
2014-12-27packages: Add 'file-type' field to 'search-path-specification'....Ludovic Courtès
2014-12-14Merge branch 'master' into 'core-updates'.Ludovic Courtès
2014-11-25gnu: pkg-config: Add pkg.m4 to the cross pkg-config....Ludovic Courtès
2014-11-22gnu: pkg-config: Update to 0.28....Ludovic Courtès
2014-10-26gnu: Some cleanup based on lint checkers....Eric Bavier