Add support for '-h' (help). https://github.com/PaulStoffregen/teensy_loader_cli/pull/26 --- teensy_loader_cli.c | 4 +++- 1 file changed, 3 insertions(+), 1 deletion(-) diff --git a/teensy_loader_cli.c b/teensy_loader_cli.c index d4a6cc5..0a06209 100644 --- a/teensy_loader_cli.c +++ b/teensy_loader_cli.c @@ -37,7 +37,8 @@ void usage(const char *err) { if(err != NULL) fprintf(stderr, "%s\n\n", err); fprintf(stderr, - "Usage: teensy_loader_cli --mcu= [-w] [-h] [-n] [-b] [-v] \n" + "Usage: teensy_loader_cli --mcu= [-h] [-w] [-n] [-b] [-v] \n" + "\t-h : Print this help message\n" "\t-w : Wait for device to appear\n" "\t-r : Use hard reboot if device not online\n" "\t-s : Use soft reboot if device not online (Teensy3.x only)\n" @@ -1081,6 +1082,7 @@ void parse_flag(char *arg) int i; for(i=1; arg[i]; i++) { switch(arg[i]) { + case 'h': usage(NULL); break; case 'w': wait_for_device_to_appear = 1; break; case 'r': hard_reboot_device = 1; break; case 's': soft_reboot_device = 1; break; -- 2.7.4 id=2ebeeeb438d09142f772d56af7a600ff1d3c43bd'>refslogtreecommitdiff
AgeCommit message (Expand)Author
2020-10-23doc: Fix typo in HACKING....* HACKING (Contributing): s/informations/information/. Maxim Cournoyer
2020-01-09doc: Move "Commit Access" section from 'HACKING' to the manual....* HACKING (Commit Access): Remove. (Contributing): Update URL of the manual. * doc/contributing.texi (Commit Access): New section. (Submitting Patches): Add cross reference. Ludovic Courtès
2020-01-09doc: Add "Tracking Bugs and Patches" section....* doc/contributing.texi (Tracking Bugs and Patches): New section. (Submitting Patches): Refer to it. * doc/guix.texi: Update copyright line. * HACKING (Using emacs-debbugs): Remove. Ludovic Courtès
2019-07-13doc: Update keyserver URL....* HACKING (Commit Access): Change keyserver URL to 'keys.openpgp.org'. Leo Famulari
2019-02-11HACKING: Update key server....* HACKING (Commit Access): Recommend pool.sks-keyservers.net. Ludovic Courtès
2018-07-22doc: Fix typo (missing period)...* HACKING (Commit Access): Fix typo. Pierre Neidhardt
2017-08-19doc: Mention how to use emacs-debbugs....* HACKING (Using emacs-debbugs): Add section on using emacs-debbugs. Arun Isaac
2017-03-27maint: Give command to install the pre-push hook....* HACKING: Add 'cp' line to install the pre-push hook. Ludovic Courtès
2017-03-24maint: Mention the Signed-off-by line in 'HACKING'....* HACKING: Mention the Signed-off-by line. Clément Lassieur
2017-03-15maint: Mention guix-patches@gnu.org in 'HACKING'....Fixes <http://bugs.gnu.org/25899>. * HACKING: Mention guix-patches@gnu.org. Ludovic Courtès
2017-01-30maint: Fix invalid calls to 'info'....* HACKING <Contributing>: Remove name of the manual from the item argument. * README <Installation>: Likewise. Mathieu Lirzin
2017-01-04doc: Add a Git hook that verifies signatures before pushing....* HACKING (Commit Access): Describe the pre-push Git hook. * etc/git/pre-push: New file. Leo Famulari