Add support for '-h' (help). https://github.com/PaulStoffregen/teensy_loader_cli/pull/26 --- teensy_loader_cli.c | 4 +++- 1 file changed, 3 insertions(+), 1 deletion(-) diff --git a/teensy_loader_cli.c b/teensy_loader_cli.c index d4a6cc5..0a06209 100644 --- a/teensy_loader_cli.c +++ b/teensy_loader_cli.c @@ -37,7 +37,8 @@ void usage(const char *err) { if(err != NULL) fprintf(stderr, "%s\n\n", err); fprintf(stderr, - "Usage: teensy_loader_cli --mcu= [-w] [-h] [-n] [-b] [-v] \n" + "Usage: teensy_loader_cli --mcu= [-h] [-w] [-n] [-b] [-v] \n" + "\t-h : Print this help message\n" "\t-w : Wait for device to appear\n" "\t-r : Use hard reboot if device not online\n" "\t-s : Use soft reboot if device not online (Teensy3.x only)\n" @@ -1081,6 +1082,7 @@ void parse_flag(char *arg) int i; for(i=1; arg[i]; i++) { switch(arg[i]) { + case 'h': usage(NULL); break; case 'w': wait_for_device_to_appear = 1; break; case 'r': hard_reboot_device = 1; break; case 's': soft_reboot_device = 1; break; -- 2.7.4 mmaryrefslogtreecommitdiff
AgeCommit message (Expand)Author
2023-08-15gnu: fbreader: Fix icon.Danny Milosavljevic
2023-07-16gnu: xchm: Update to 1.35.Tobias Geerinckx-Rice
2023-04-03gnu: calibre: Update to 5.44.0.Andreas Enge
2023-04-03gnu: calibre: Fix build.Andreas Enge
2023-02-19gnu: Use HTTPS package home pages wherever possible.Tobias Geerinckx-Rice
2023-02-17gnu: Make nothing depend on QtWebKit.Leo Famulari
2023-01-04gnu: hunspell: Move hunspell and dictionaries to hunspell module.Brian Cully
2022-11-28gnu: calibre: Add missing python-pycryptodome dependency.Andrew Tropin
2022-11-20gnu: inkbox: Fix build.Marius Bakke
2022-11-20gnu: inkbox: Update home-page and source URI.Marius Bakke
2022-09-16gnu: Add shirah.M
2022-09-16gnu: Add python-ebooklib.M
2022-08-21gnu: cozy: Update to 1.2.1.Vinicius Monego
2022-07-31gnu: qtwebengine: Rename to qtwebengine-5.Maxim Cournoyer
2022-07-31gnu: qtsvg: Rename variable to qtsvg-5.Maxim Cournoyer