This patch ensures that the 'tclIndex' files generated by 'auto_mkindex' are sorted in a deterministic fashion. Fixes a non-determinism issue reported at . --- tcl8.6.4/library/auto.tcl 2015-02-26 17:57:28.000000000 +0100 +++ tcl8.6.4/library/auto.tcl 2015-11-13 23:18:34.964831717 +0100 @@ -207,6 +207,9 @@ proc auto_mkindex {dir args} { set args *.tcl } + # Keep file names sorted in a determistic order. + set args [lsort -ascii $args] + auto_mkindex_parser::init foreach file [glob -- {*}$args] { try { @@ -241,6 +244,10 @@ proc auto_mkindex_old {dir args} { if {![llength $args]} { set args *.tcl } + + # Keep file names sorted in a determistic order. + set args [lsort -ascii $args] + foreach file [glob -- {*}$args] { set f "" set error [catch { '/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/build/install.scm
AgeCommit message (Expand)Author
2019-03-07activation: Build account databases with (gnu build accounts)....Ludovic Courtès
2018-11-06install: Add 'install-database-and-gc-roots'....Ludovic Courtès
2018-11-06pack: Import (guix store database) only when '--localstatedir' is passed....Ludovic Courtès
2018-11-06pack: Move store database creation to a separate derivation....Ludovic Courtès
2018-11-05install: Parameterize the profile name for 'populate-single-profile-directory'....Ludovic Courtès
2018-10-21install: Make /var/guix/…/guix-profile a relative symlink....Ludovic Courtès
2018-06-14Remove 'guix-register' and its traces....Ludovic Courtès
2018-06-14database: Allow for deterministic database construction....Ludovic Courtès
2018-06-14install: Use 'reset-timestamps' from (guix store database)....Ludovic Courtès
2018-06-14database: Add 'register-items'....Ludovic Courtès
2018-06-14install: Use (guix store database) instead of 'guix-register'....Ludovic Courtès
2017-05-16bootloader: Adapt vm to new bootloader API....Mathieu Othacehe