Description: Don't lookup previous point if there isn't any Author: Marc Deslauriers Forwarded: no Index: t1lib-5.1.2/lib/type1/type1.c =================================================================== --- t1lib-5.1.2.orig/lib/type1/type1.c 2011-12-13 14:24:14.280965637 -0600 +++ t1lib-5.1.2/lib/type1/type1.c 2011-12-13 14:25:25.893320747 -0600 @@ -1700,6 +1700,7 @@ long pindex = 0; /* compute hinting for previous segment! */ + if (ppoints == NULL) Error0i("RLineTo: No previous point!\n"); FindStems( currx, curry, currx-ppoints[numppoints-2].x, curry-ppoints[numppoints-2].y, dx, dy); /* Allocate a new path point and pre-setup data */ @@ -1728,6 +1729,7 @@ long pindex = 0; /* compute hinting for previous point! */ + if (ppoints == NULL) Error0i("RRCurveTo: No previous point!\n"); FindStems( currx, curry, currx-ppoints[numppoints-2].x, curry-ppoints[numppoints-2].y, dx1, dy1); /* Allocate three new path points and pre-setup data */ @@ -1903,6 +1905,7 @@ FindStems( currx, curry, 0, 0, dx, dy); } else { + if (ppoints == NULL) Error0i("RMoveTo: No previous point!\n"); FindStems( currx, curry, ppoints[numppoints-2].x, ppoints[numppoints-2].y, dx, dy); } u/packages/llvm-meta.scm?showmsg=1'>logtreecommitdiff
path: root/gnu/packages/llvm-meta.scm
AgeCommit message (Collapse)Author
2024-09-30gnu: clang-19: Add compiler-cpu-architectures entries.Efraim Flashner
* gnu/packages/llvm-meta.scm (clang-compiler-cpu-architectures): Add entries for powerpc64le and x86_64 for new optimization architectures. Change-Id: Ie89dd4cb17c36e0a9faba37f54c0c24bcf3e7727
2024-03-26gnu: clang-18: Add compiler-cpu-architectures entry.Efraim Flashner
* gnu/packages/llvm-meta.scm (clang-compiler-cpu-architectures): Add entry for x86_64 for clang-18 for new optimization architectures. Change-Id: I6301c28b5032caf520aa974c70c500e12d088e63
2024-03-10cpu: Remove duplicate clang-compiler-cpu-architecture entry.Efraim Flashner
* gnu/packages/llvm-meta.scm (clang-compiler-cpu-architectures): Remove x86_64 version 15 entry since it is unchanged from the version 13 entry. Change-Id: Ifb845993e2deec842dfbe8f9b72944457aa7e98e
2024-03-10gnu: clang: Move compiler-cpu-architectures to llvm-meta.scm.Efraim Flashner
* gnu/packages/llvm.scm (clang-properties): Extract compiler-cpu-architectures and move ... * gnu/packages/llvm-meta.scm: ... to here. * gnu/packages/zig.scm (zig-0.9, zig-0.10)[properties]: Use clang-compiler-cpu-architectures. * gnu/local.mk (GNU_SYSTEM_MODULES): Register new file. Change-Id: Ie0bedbd6e2927eaa05024685cc66375ea278e4c2