Description: Don't lookup previous point if there isn't any Author: Marc Deslauriers Forwarded: no Index: t1lib-5.1.2/lib/type1/type1.c =================================================================== --- t1lib-5.1.2.orig/lib/type1/type1.c 2011-12-13 14:24:14.280965637 -0600 +++ t1lib-5.1.2/lib/type1/type1.c 2011-12-13 14:25:25.893320747 -0600 @@ -1700,6 +1700,7 @@ long pindex = 0; /* compute hinting for previous segment! */ + if (ppoints == NULL) Error0i("RLineTo: No previous point!\n"); FindStems( currx, curry, currx-ppoints[numppoints-2].x, curry-ppoints[numppoints-2].y, dx, dy); /* Allocate a new path point and pre-setup data */ @@ -1728,6 +1729,7 @@ long pindex = 0; /* compute hinting for previous point! */ + if (ppoints == NULL) Error0i("RRCurveTo: No previous point!\n"); FindStems( currx, curry, currx-ppoints[numppoints-2].x, curry-ppoints[numppoints-2].y, dx1, dy1); /* Allocate three new path points and pre-setup data */ @@ -1903,6 +1905,7 @@ FindStems( currx, curry, 0, 0, dx, dy); } else { + if (ppoints == NULL) Error0i("RMoveTo: No previous point!\n"); FindStems( currx, curry, ppoints[numppoints-2].x, ppoints[numppoints-2].y, dx, dy); } f19893bfdb2526'>treecommitdiff
path: root/tests/cve.scm
0'>2020-05-13
AgeCommit message (Expand)Author
2019-10-23cve: Rewrite to read the JSON feed instead of the XML feed....Ludovic Courtès
2019-10-20tests: Avoid now-deprecated 'make-struct'....Ludovic Courtès
2016-05-28cve: Use a more compact format for the list of package/versions....Ludovic Courtès
2016-04-03build: Add a Guile custom test driver using SRFI-64....Mathieu Lirzin
2015-11-26Add (guix cve)....Ludovic Courtès
mailmap: Update entries for Nikita....nikita
2020-03-08services: certbot: Add server option....Jack Hill
2019-09-16services: certbot: Add --manual-public-ip-logging-ok for manual challenges...Carlo Zancanaro
2019-04-25gnu: certbot: Add support for manual plugin....Julien Lepiller
2019-03-18Correct name and email address for ng0....ng0