Description: Don't lookup previous point if there isn't any Author: Marc Deslauriers Forwarded: no Index: t1lib-5.1.2/lib/type1/type1.c =================================================================== --- t1lib-5.1.2.orig/lib/type1/type1.c 2011-12-13 14:24:14.280965637 -0600 +++ t1lib-5.1.2/lib/type1/type1.c 2011-12-13 14:25:25.893320747 -0600 @@ -1700,6 +1700,7 @@ long pindex = 0; /* compute hinting for previous segment! */ + if (ppoints == NULL) Error0i("RLineTo: No previous point!\n"); FindStems( currx, curry, currx-ppoints[numppoints-2].x, curry-ppoints[numppoints-2].y, dx, dy); /* Allocate a new path point and pre-setup data */ @@ -1728,6 +1729,7 @@ long pindex = 0; /* compute hinting for previous point! */ + if (ppoints == NULL) Error0i("RRCurveTo: No previous point!\n"); FindStems( currx, curry, currx-ppoints[numppoints-2].x, curry-ppoints[numppoints-2].y, dx1, dy1); /* Allocate three new path points and pre-setup data */ @@ -1903,6 +1905,7 @@ FindStems( currx, curry, 0, 0, dx, dy); } else { + if (ppoints == NULL) Error0i("RMoveTo: No previous point!\n"); FindStems( currx, curry, ppoints[numppoints-2].x, ppoints[numppoints-2].y, dx, dy); } packages/textutils.scm?id=d5abbf48a447813b526b6dd05816cf15c2f06938'>treecommitdiff
path: root/gnu/packages/textutils.scm
AgeCommit message (Expand)Author
2023-07-09gnu: antiword: Use Web Archive URLs....Tobias Geerinckx-Rice
2023-06-21gnu: go-github-com-mattn-go-runewidth: Update to 0.0.14....Nguyễn Gia Phong
2023-06-20gnu: utf8proc-2.7.0: Explicitly use ruby-2.7....Christopher Baines
2023-06-08gnu: Add pandoc-include....Wiktor Żelazny
2023-06-08gnu: Add python-panflute....Wiktor Żelazny
2023-05-21gnu: dos2unix: Update to 7.5.0....Timotej Lazar
2023-04-10gnu: libconfig: Replace config script helpers....Efraim Flashner
2023-03-21gnu: dbacl: Fix failing check phase....Danny O'Brien
2023-03-02gnu: dos2unix: Use new package style....Timotej Lazar
2023-03-02gnu: dos2unix: Update to 7.4.4....Timotej Lazar
2023-02-19gnu: Use HTTPS package home pages wherever possible....Tobias Geerinckx-Rice