diff --git a/lib/t1lib/parseAFM.c b/lib/t1lib/parseAFM.c index 6a31d7f..ba64541 100644 --- a/lib/t1lib/parseAFM.c +++ b/lib/t1lib/parseAFM.c @@ -199,7 +199,9 @@ static char *token(stream) idx = 0; while (ch != EOF && ch != ' ' && ch != CR && ch != LF && - ch != CTRL_Z && ch != '\t' && ch != ':' && ch != ';'){ + ch != CTRL_Z && ch != '\t' && ch != ':' && ch != ';' + && idx < (MAX_NAME -1)) + { ident[idx++] = ch; ch = fgetc(stream); } /* while */ @@ -235,7 +237,7 @@ static char *linetoken(stream) while ((ch = fgetc(stream)) == ' ' || ch == '\t' ); idx = 0; - while (ch != EOF && ch != CR && ch != LF && ch != CTRL_Z) + while (ch != EOF && ch != CR && ch != LF && ch != CTRL_Z && idx < (MAX_NAME - 1)) { ident[idx++] = ch; ch = fgetc(stream); ipts'>koszko-scripts Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/tests/services.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-02-17 17:14:31 +0000
committerChristopher Baines <mail@cbaines.net>2019-03-04 20:33:21 +0000
commit93dc8684cf5f72d88dbd969f6d363e2a6381314a (patch)
tree67f5f28f4a017f667b9caad7173f78da97fc4b22 /tests/services.scm
parentd6084cdb12f85b4e6bf3db8485a44cc9514cfab5 (diff)
downloadguix-93dc8684cf5f72d88dbd969f6d363e2a6381314a.tar.gz
guix-93dc8684cf5f72d88dbd969f6d363e2a6381314a.zip
gnu: Add ruby-test-construct.
* gnu/packages/ruby.scm (ruby-test-construct): New variable.
Diffstat (limited to 'tests/services.scm')
0 files changed, 0 insertions, 0 deletions