diff --git a/lib/t1lib/parseAFM.c b/lib/t1lib/parseAFM.c index 6a31d7f..ba64541 100644 --- a/lib/t1lib/parseAFM.c +++ b/lib/t1lib/parseAFM.c @@ -199,7 +199,9 @@ static char *token(stream) idx = 0; while (ch != EOF && ch != ' ' && ch != CR && ch != LF && - ch != CTRL_Z && ch != '\t' && ch != ':' && ch != ';'){ + ch != CTRL_Z && ch != '\t' && ch != ':' && ch != ';' + && idx < (MAX_NAME -1)) + { ident[idx++] = ch; ch = fgetc(stream); } /* while */ @@ -235,7 +237,7 @@ static char *linetoken(stream) while ((ch = fgetc(stream)) == ' ' || ch == '\t' ); idx = 0; - while (ch != EOF && ch != CR && ch != LF && ch != CTRL_Z) + while (ch != EOF && ch != CR && ch != LF && ch != CTRL_Z && idx < (MAX_NAME - 1)) { ident[idx++] = ch; ch = fgetc(stream); ion> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/bootloader/grub.scm
AgeCommit message (Expand)Author
2024-01-14bootloader: grub: Add support for loading an additional initrd....Tomas Volf
2023-07-13bootloader: grub: Use rumpdisk-style root when booting with "noide"....Janneke Nieuwenhuizen
2022-12-07bootloaders: grub: Fix comment....Maxim Cournoyer
2022-12-01gnu: bootloader: Rework chaining, add grub-efi-netboot-removable-bootloader....Stefan
2022-09-08gnu: bootloader: grub: Add support for chain-loader....tiantian
2022-06-24image: Add support for 32bit UEFI....Denis 'GNUtoo' Carikli
2022-06-06bootloader: grub: Add removable grub-efi bootloader option....Karl Hallsby
2022-01-13bootloader: grub: Fix serial mode....Mathieu Othacehe
2021-12-01gnu: system: Add LUKS2 support for the root file system....Josselin Poiret
2021-08-29Migrate to the new 'targets' field of bootloader-configuration....Maxim Cournoyer
2021-04-10bootloader: grub: Fix typo in docstring....Tobias Geerinckx-Rice