diff -ru src/part.c b/part.c
--- src/part.c Thu May 14 06:01:00 2009 -0400
+++ b/part.c Thu May 14 06:01:00 2009 -0400
@@ -1767,8 +1767,8 @@
/* to compute number of partitions */
{
INT erg = OK;
- if (ni<0) return;
- if (not EMPTYP(S_V_I(vec,ni))) return;
+ if (ni<0) return 0;
+ if (not EMPTYP(S_V_I(vec,ni))) return 0;
else if (ni<=1) M_I_I(1,S_V_I(vec,ni));
else {
oszko.org/cgit-static/cgit.png' alt='cgit logo'/>
type='submit' value='search'/>
Age | Commit message (Expand) | Author |
2021-09-15 | import: cabal: Treat identifier names correctly....* guix/import/cabal.scm (is-id): Accept the location as an argument. Don’t
check if the identifier name is a reserved keyword unless it is the first word
on the line.
(lex-word): Adjust accordingly.
* tests/hackage ("hackage->guix-package tests flag executable"): Expect it to
pass.
Fixes: <https://issues.guix.gnu.org/25138>
Signed-off-by: Lars-Dominik Braun <lars@6xq.net>
| Xinglu Chen |
2021-06-25 | import: hackage: Support "common" field and imports...Fixes <https://issues.guix.gnu.org/48701>.
* guix/import/cabal.scm (make-cabal-parser): Modify.
(is-common): New variable.
(lex-common): New procedure.
(is-id): Modify.
(eval-cabal): Modify.
* tests/hackage.scm ("hackage->guix-package test cabal import") New test.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Philip Munksgaard |
2021-05-22 | import: hackage: Prefix licenses with 'license:'....* guix/import/hackage.scm (string->license): Prefix the value of the license
field with ‘license:’.
* tests/hackage.scm (match-ghc-foo, match-ghc-foo-6, match-ghc-foo-revision):
Adjust accordingly.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Xinglu Chen |