diff -ru src/part.c b/part.c
--- src/part.c Thu May 14 06:01:00 2009 -0400
+++ b/part.c Thu May 14 06:01:00 2009 -0400
@@ -1767,8 +1767,8 @@
/* to compute number of partitions */
{
INT erg = OK;
- if (ni<0) return;
- if (not EMPTYP(S_V_I(vec,ni))) return;
+ if (ni<0) return 0;
+ if (not EMPTYP(S_V_I(vec,ni))) return 0;
else if (ni<=1) M_I_I(1,S_V_I(vec,ni));
else {
ref='/'>
index : guix | |
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2024-09-14 | gnu: smalltalk: Disable tests on x86-64....* gnu/packages/smalltalk.scm (smalltalk)[arguments]: Disable tests on x86-64.
Change-Id: I6838e94545df4c11f048b06dfbfd99358bf240a3
| Guillaume Le Vaillant |
2024-09-13 | gnu: smalltalk: Fix tests....* gnu/packages/smalltalk.scm (smalltalk)[native-inputs]: Add
'(libc-utf8-locales-for-target)'.
Change-Id: Idf49394e5c4dbd3398a6774319184339ed18585c
Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
| Greg Hogan |