diff -ru src/def.h c/def.h --- src/def.h 2007-12-06 17:30:56.000000000 +0100 +++ c/def.h 2013-10-19 18:42:55.118745730 +0200 @@ -2,14 +2,9 @@ /* INT should always be 4 byte */ #ifndef DEF_H - -#ifdef __alpha -typedef int INT; -typedef unsigned int UINT; -#else /* __alpha */ -typedef long INT; -typedef unsigned long UINT; -#endif /* __alpha */ +#include +typedef int32_t INT; +typedef uint32_t UINT; #include #include @@ -65,10 +60,13 @@ /* definitionen fuer object.c */ -typedef INT OBJECTKIND; /* 4 byte */ +/* NOTE: partition code assumes that there is no unused space in the + * object struct when an INT is stored. This requires both OBJECTKIND + * and OBJECTSELF to have a size equal to a machine word. */ +typedef intptr_t OBJECTKIND; typedef union { - INT ob_INT; + intptr_t ob_INT; INT * ob_INTpointer; char *ob_charpointer; struct bruch *ob_bruch; tr>Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
AgeCommit message (Expand)Author
2020-06-13gnu: libnode: Delete unused phase....This is a follow-up to commit bb310a1976198eacdc67e0712e19735cd656b21d. * gnu/packages/node.scm (libnode)[arguments]: Delete phase "patch-npm-shebang". Ricardo Wurmus
2020-06-13Revert "gnu: node: Build shared library."...This reverts commit f9311eaa7cb7849e9b17162c93b874c74d8fcbbd. Adding "--shared" replaces the executable with the shared library, breaking all users of the nodejs executable. Ricardo Wurmus
2020-06-13gnu: Add libnode....* gnu/packages/node.scm (libnode): New variable. Ricardo Wurmus
2020-06-13gnu: node: Build shared library....* gnu/packages/node.scm (node)[arguments]: Build shared library. Ricardo Wurmus
2020-03-04Merge branch 'master' into core-updatesMarius Bakke
2020-02-26gnu: node: Disable failing tests on armhf-linux....* gnu/packages/node.scm (node)[arguments]: When building on armhf-linux, disable several zlib tests. Marius Bakke
2020-02-26gnu: node: Update to 10.19.0....* gnu/packages/node.scm (node): Update to 10.19.0. [inputs]: Remove LIBUV and NGHTTP2:LIB. Add LIBUV/LATEST and NGHTTP2-1.40:LIB. Marius Bakke
2020-02-24gnu: node: Increase build timeouts....* gnu/packages/node.scm (node)[properties]: Add MAX-SILENT-TIME. Increase TIMEOUT from 3600 seconds to 14400. Marius Bakke
2020-02-14Merge branch 'master' into core-updatesMarius Bakke
2020-02-10gnu: node: Disable flaky test....* gnu/packages/node.scm (node)[arguments]: Delete test that fails sporadically. Marius Bakke