--- src/bruch.c 2007-12-06 11:30:00.000000000 -0500 +++ b/bruch.c 2013-10-22 08:37:43.000000000 -0400 @@ -975,14 +975,16 @@ ggterg = ggt_i(S_B_UI(bruch),S_B_OI(bruch)); if (ggterg == S_B_UI(bruch)) { + INT tmp = S_B_OI(bruch); freeself_bruch(bruch); - M_I_I(S_B_OI(bruch) / ggterg,bruch); + M_I_I(tmp / ggterg,bruch); goto ende; } if (-ggterg == S_B_UI(bruch)) { + INT tmp = S_B_OI(bruch); freeself_bruch(bruch); - M_I_I(- S_B_OI(bruch) / ggterg,bruch); + M_I_I(- tmp / ggterg,bruch); goto ende; } @@ -1032,12 +1034,14 @@ if (S_O_K(S_B_U(bruch)) == INTEGER) if (S_B_UI(bruch) == 1) { + INT tmp = S_B_OI(bruch); freeself_bruch(bruch); - M_I_I(S_B_OI(bruch),bruch); + M_I_I(tmp,bruch); goto ende; } else if (S_B_UI(bruch) == -1) { + INT tmp = S_B_OI(bruch); freeself_bruch(bruch); - M_I_I( - S_B_OI(bruch),bruch); + M_I_I( - tmp,bruch); goto ende; } if (NEGP(S_B_O(bruch)) && NEGP(S_B_U(bruch))) { aa9'>refslogtreecommitdiff
path: root/gnu/packages/password-utils.scm
AgeCommit message (Expand)Author
2024-07-23gnu: keepassxc: Update to 2.7.9....Nicolas Goaziou
2024-06-26gnu: Add rofi-pass-wayland....John Kehayias
2024-06-26gnu: rofi-pass: Update to 2.0.2-0.8aa6b92....John Kehayias
2024-06-11gnu: keepassxc: Update to 2.7.8....Timotej Lazar
2024-04-06gnu: go-github-com-mattn-go-zglob: Move to golang-xyz....Sharlatan Hellseher
2024-03-26gnu: Add zxcvbn-c....Efraim Flashner
2024-03-17gnu: keepassxc: Update to 2.7.7....Nicolas Goaziou
2024-03-12gnu: ssh-to-age: Update to 1.1.7....Giacomo Leidi
2024-03-01gnu: Add bruteforce-salted-openssl....Guillaume Le Vaillant
2024-03-01gnu: bruteforce-luks: Update to 1.4.1....Guillaume Le Vaillant
2024-02-26gnu: Add pass-coffin...Christian Miller via Guix-patches via
2024-02-13gnu: go-golang-org-x-sys: Move to golang-build....Sharlatan Hellseher
2024-02-13gnu: qtpass: Switch to qt-build-system and new package style....Timotej Lazar
2024-02-13gnu: qtpass: Update to 1.4.0....Timotej Lazar
2024-01-28gnu: go-filippo-io-edwards25519: Move to (gnu packages golang-crypto)....Sharlatan Hellseher