--- src/bruch.c 2007-12-06 11:30:00.000000000 -0500 +++ b/bruch.c 2013-10-22 08:37:43.000000000 -0400 @@ -975,14 +975,16 @@ ggterg = ggt_i(S_B_UI(bruch),S_B_OI(bruch)); if (ggterg == S_B_UI(bruch)) { + INT tmp = S_B_OI(bruch); freeself_bruch(bruch); - M_I_I(S_B_OI(bruch) / ggterg,bruch); + M_I_I(tmp / ggterg,bruch); goto ende; } if (-ggterg == S_B_UI(bruch)) { + INT tmp = S_B_OI(bruch); freeself_bruch(bruch); - M_I_I(- S_B_OI(bruch) / ggterg,bruch); + M_I_I(- tmp / ggterg,bruch); goto ende; } @@ -1032,12 +1034,14 @@ if (S_O_K(S_B_U(bruch)) == INTEGER) if (S_B_UI(bruch) == 1) { + INT tmp = S_B_OI(bruch); freeself_bruch(bruch); - M_I_I(S_B_OI(bruch),bruch); + M_I_I(tmp,bruch); goto ende; } else if (S_B_UI(bruch) == -1) { + INT tmp = S_B_OI(bruch); freeself_bruch(bruch); - M_I_I( - S_B_OI(bruch),bruch); + M_I_I( - tmp,bruch); goto ende; } if (NEGP(S_B_O(bruch)) && NEGP(S_B_U(bruch))) { treecommitdiff
path: root/m4
AgeCommit message (Expand)Author
2020-07-20ssh: Speed up RPCs by using #:nodelay....Lars-Dominik Braun
2020-05-28doc: Remove explicit support for mips64el-linux....Efraim Flashner
2020-05-28maint: Check whether Guile-Gcrypt is recent enough....Ludovic Courtès
2020-02-22build: Depend on guile-ssh 0.12.0...Lars-Dominik Braun
2019-08-17build: 'GUIX_CHECK_GUILE_JSON' really checks for Guile-JSON 3.x....Ludovic Courtès
2019-07-25maint: Switch to Guile-JSON 3.x....Ludovic Courtès
2019-05-06Add (guix lzlib)....Pierre Neidhardt
2018-11-23Update Guile-SQLite3 URL everywhere....Ludovic Courtès
2018-09-04Switch to Guile-Gcrypt....Ludovic Courtès
2018-06-01build: Check for Guile-SQLite3....Ludovic Courtès
2018-02-26build: Require Guile >= 2.0.13....Ludovic Courtès
2018-01-06build: Detect broken 'equal?' in Guile 2.2.1....Ludovic Courtès
2017-06-30build: Remove check for broken (srfi srfi-37)....Ludovic Courtès
2017-02-20gnu: Add bootstrap-binaries for 'aarch64-linux'....Efraim Flashner
2016-11-25offload: Use Guile-SSH instead of GNU lsh....Ludovic Courtès
2016-08-10build: Correctly determine the system type for GNU/Hurd systems....Manolis Ragkousis
2016-07-20Merge branch 'master' into core-updatesLudovic Courtès
2016-07-19Add (guix zlib)....Ludovic Courtès
2016-06-23build: Remove unneeded conditionals for (guix build syscalls)....Manolis Ragkousis