From http://swish-e.org/archive/2015-09/13295.html --- a/src/compress.c +++ a/src/compress.c @@ -995,7 +995,7 @@ void remove_worddata_longs(unsigned char *worddata,int *sz_worddata) progerr("Internal error in remove_worddata_longs"); /* dst may be smaller than src. So move the data */ - memcpy(dst,src,data_len); + memmove(dst,src,data_len); /* Increase pointers */ src += data_len; --- a/src/headers.c +++ a/src/headers.c @@ -280,7 +280,7 @@ static SWISH_HEADER_VALUE fetch_single_header( IndexFILE *indexf, HEADER_MAP *he case SWISH_NUMBER: case SWISH_BOOL: - value.number = *(unsigned long *) data_pointer; + value.number = *(unsigned int *) data_pointer; /* $$$ Ugly hack alert! */ /* correct for removed files */ --- a/src/swishspider +++ a/src/swishspider @@ -27,6 +27,7 @@ use LWP::UserAgent; use HTTP::Status; use HTML::Parser 3.00; use HTML::LinkExtor; +use Encode; if (scalar(@ARGV) != 2) { print STDERR "Usage: $0 localpath url\n"; @@ -94,7 +95,7 @@ use HTML::LinkExtor; # Don't allow links above the base $URI::ABS_REMOTE_LEADING_DOTS = 1; - $p->parse( $$content_ref ); + $p->parse( decode_utf8 $$content_ref ); close( LINKS ); exit; fef465b2b2353610cbff2caefee679566978f7'>commitdiff
path: root/tests
diff options
context:
space:
mode:
authorPicnoir <picnoir@alternativebit.fr>2024-05-19 14:46:23 +0200
committerLudovic Courtès <ludo@gnu.org>2024-06-02 20:52:25 +0200
commitabfef465b2b2353610cbff2caefee679566978f7 (patch)
tree67bb8ae802731ec770e09ed9f6a510d46fddc57e /tests
parentaed9a0e96e847a97b3309ce768f4ed23fa73b656 (diff)
downloadguix-abfef465b2b2353610cbff2caefee679566978f7.tar.gz
guix-abfef465b2b2353610cbff2caefee679566978f7.zip
gnu: Add rust-dns-lookup-2.
* gnu/packages/crates-io.scm (rust-dns-lookup-2): New variable. Required by Nsncd. Change-Id: I66a8488c93cc0c119417270db93733424a791069 Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'tests')
0 files changed, 0 insertions, 0 deletions