From http://swish-e.org/archive/2015-09/13295.html --- a/src/compress.c +++ a/src/compress.c @@ -995,7 +995,7 @@ void remove_worddata_longs(unsigned char *worddata,int *sz_worddata) progerr("Internal error in remove_worddata_longs"); /* dst may be smaller than src. So move the data */ - memcpy(dst,src,data_len); + memmove(dst,src,data_len); /* Increase pointers */ src += data_len; --- a/src/headers.c +++ a/src/headers.c @@ -280,7 +280,7 @@ static SWISH_HEADER_VALUE fetch_single_header( IndexFILE *indexf, HEADER_MAP *he case SWISH_NUMBER: case SWISH_BOOL: - value.number = *(unsigned long *) data_pointer; + value.number = *(unsigned int *) data_pointer; /* $$$ Ugly hack alert! */ /* correct for removed files */ --- a/src/swishspider +++ a/src/swishspider @@ -27,6 +27,7 @@ use LWP::UserAgent; use HTTP::Status; use HTML::Parser 3.00; use HTML::LinkExtor; +use Encode; if (scalar(@ARGV) != 2) { print STDERR "Usage: $0 localpath url\n"; @@ -94,7 +95,7 @@ use HTML::LinkExtor; # Don't allow links above the base $URI::ABS_REMOTE_LEADING_DOTS = 1; - $p->parse( $$content_ref ); + $p->parse( decode_utf8 $$content_ref ); close( LINKS ); exit; /commit/tests/syscalls.scm?id=73d747524629e7ffa38c2e1302bcafa299d3fcee'>commitdiff
path: root/tests/syscalls.scm
AgeCommit message (Expand)Author
2018-07-03syscalls: Define AT_SYMLINK_NOFOLLOW et al....Ludovic Courtès
2018-04-08tests: Skip 'pivot-root' test on Ubuntu's 4.4 kernels....Ludovic Courtès
2017-11-25syscalls: Adjust utmpx test....Ludovic Courtès
2017-07-12syscalls: Add network-interface-running?...Danny Milosavljevic
2017-06-16syscalls: Add 'scandir*'....Ludovic Courtès
2017-05-28syscalls: Add 'thread-name' and 'set-thread-name'....Ludovic Courtès
2017-02-11tests: Relax test on utmpx entries....Ludovic Courtès
2017-01-31tests: Really skip /var/run/utmpx test when needed....Paul Garlick
2017-01-24syscalls: Export 'read-utmpx'....Ludovic Courtès
2017-01-19syscalls: Add utmpx procedures and data structure....Ludovic Courtès
2016-11-21syscalls: Add 'add-network-route/gateway' and 'delete-network-route'....Ludovic Courtès
2016-11-16syscalls: Add bindings for SIOCGIFNETMASK and SIOCSIFNETMASK....Ludovic Courtès
2016-10-27tests: Skip 'pivot-root' test on Linux > 4.7.5....Ludovic Courtès
2016-10-19tests: Make sure child process of 'pivot-root' test exits....Ludovic Courtès